Mechanics

CHRYSLER TOWN AND COUNTRY TRANSMISSION PROBLEM

2001 Chrysler Town and Country

Hello, I have a 2001Chrysler Town and Country (3.8 l engine)that I just had the transmission rebuilt on. It has around 65K miles on it and it has started to have a strange problem.

On occasion while driving the speedometer will drop and the car feels like it is trying to hold itself back, the tachometer doesn't change but the cruise control light kicks on.

This occurs only momentarily and then the car drives normally.

The problem occurs at random as well.

Any ideas?
Avatar
Ptangzot
May 9, 2007.




Have the vehicle speed sensor check also the computer uses the VSS to control the cruise control operation
AD

Tiny
Rasmataz
May 9, 2007.
Well the car has been in the Garage for a total of 7 days.

So far we have changed both the input and output speed sensors, the transmission range sensor, the transmission temperature sensor, the TCM and the wiring harnesses on the transmission and we still have the problem.

This has been a nightmare, the TCM was listing three active alarms but no check engine light activated. It kept saying the tranmsission was operating at 1000 deg F and it was not reporting the proper transmission range. The place I am using even sent the car to the Dealership and they have not been able to figure out what is going on.I am not a happy person about this.

Tiny
Ptangzot
May 18, 2007.
Still having this problem. Does anyone have any other ideas?

Thanks!

Tiny
Ptangzot
Jun 7, 2007.

AD