Mechanics

93 CHEVY S10 BLAZER RUNS CRAPPY. 4.3 VORTEC

1993 Chevrolet Truck

I got this truck for 100 bucks, great condition, the guy said the motor was locked up, I took it home, it wasnt, a batt. Cable was loose, it ran rough, the heads were blown, I fixed that, it ran fine for 2 weeks, then the check engine light would come on, it idled rough, ran rich, stalled out, wouldnt start, I ran dionogstics on it, a map sensor code, iac code and a tps code, I replaced those and the o2 sensor and the plugs, the touble codes are clear, but it still runs poorly, I ran a compression check, all 6 cylinders are within specs, there is no water in the oil or vice versa, can anyone know how these vortecs, work, thanks : x
Avatar
Smokinfloyd4.3
January 3, 2006.




Dosnt the car have fuel pressure? : D

2CarPros Ken
Jan 4, 2006.
I have considered fuel delivery, but with it running rich, and getting poor fuel economy, wouldnt that mean the engine is getting plenty of fuel? What kind of fuel pressure is the CPI 4.3 supposed to have anyway? Also, are the CPI units ( aka the spider) a common area of trouble? Ive been told these are prone to failure, how true is this? I dont know much about the vortec, I am more familiar with the TBI system.
I will check fuel pressure if I can get the specs and get the motor started, thanks for any more suggestions.
John
AD

Tiny
Smokinfloyd4.3
Jan 5, 2006.
When the truck is running, it keeps a constant temp of 210 degrees, no higher, is this normal, bad, or is my gauge in accurate?

Tiny
Smokinfloyd4.3
Jan 5, 2006.
Oh yeah my transfer case engages and works but the front axle doesnt pull, only when it wants to, I figure all these troubles out, ill have a perfect blazer.

Tiny
Smokinfloyd4.3
Jan 5, 2006.

AD