Mechanics

CHEVY SPEEDOMETER, DASHBOARD AND STEREO ISSUES

2004 Chevrolet S-10

Electrical problem
2004 Chevy S-10 Four Wheel Drive Automatic

Over the weekend, my husband and I attempted to replace the stock stereo with an old Rockford Fosgate. Unfortunately we found the Rockford's CD player didn't function so we pulled it out and put the old stock back in. However, now I'm facing a myriad of issues. The stereo (the old stock) doesn't seem to be getting power. I read up on the Theftlock system but don't think that's the problem. According to what I read " LOC" would be flashing if it was in a theft-locking mode. However, we have no power, no clock, etc. And it wasn't until this morning that I needed to drive to work and found my entire dashboard seems to be 'out'. The dash lights work but the gas gauge, speedometer, etc don't work. As a side note, the blinkers did light up on the dash when I used them, however the brights do not light up on the dash.

I'm sorry this is so long but due to my husband's work schedule, I'm not sure when he'll have a chance to look into this and reconnect anything that may be just loose. Please help!
Avatar
Mrs_nielsen
December 8, 2008.




First check the fuses for the interior, they are located in both the dash fuse panel and the underhood panel. If they are OK then you may have damaged the body control module or the wiring harness or both. That vehicle isn't easy to install an after market stereo in because the factory unit is connect to the data buss and the ECM and BCM. Pull the dash back apart and check the wiring, if you cut any wires check them real close and a touch of prayer won't hurt. You're description isn't good though. Sorry.

Tiny
SWilliams
Dec 12, 2008.


AD