Mechanics

CHEVY WINDSHILED WIPERS NOT WORKING

1998 Chevrolet S-10

Electrical problem
1998 Chevy S-10 6 cyl Two Wheel Drive Automatic 156000 miles

I have had the same problem as many other s10 owners have had, where the wipers used to work (intermittently), now they dont work at all. I have replaced the connector to the motor and it worked great, very briefly. I read on some forums to re-solder some of the connections on the board. I did them all, and still nothing. Please help. 98, 4.3l, 2wd
Avatar
Kdizzy42
April 13, 2009.




Have you considered replacing the pulse board? I have seen two Blazers with similar problem, and the pulse board replacement cured the problem.


http://www.2carpros.com/forum/automotive_pictures/55316_906136007_1.jpg


Available at your local parts store, Dorman 88136 retails for about $30.

Tiny
Zackman
Apr 13, 2009.
I will give that a try and let you know. Thanks

Tiny
Kdizzy42
Apr 14, 2009.
Please do.

Tiny
Zackman
Apr 14, 2009.
I have replaced the pulse board module, and still nothing, the fuse is good(obviously) is it possible that I have a bad ground or something?
AD

Tiny
Kdizzy42
Apr 15, 2009.
It is quite possible. Here is the diagnostic for your problem and the wiring diagram.


http://www.2carpros.com/forum/automotive_pictures/55316_98s10wiper1_1.jpg



http://www.2carpros.com/forum/automotive_pictures/55316_98s10wiper2_1.jpg



http://www.2carpros.com/forum/automotive_pictures/55316_98s10wiper3_1.jpg


Tiny
Zackman
Apr 15, 2009.
Thank you very much for the diagnostic and wiring diagram. This will definitely get me to the bottom of the issue. Ive looked in several places for the diagram, but to no avail. Thanks again.

Tiny
Kdizzy42
Apr 16, 2009.
Glad to help. Let me know if you need anything else.

Tiny
Zackman
Apr 16, 2009.

AD