Mechanics

CHEVY TRANSMISSION GRINDS SOME GOING INTO 2ND AND

1996 Chevrolet S-10

Transmission problem
1996 Chevy S-10 4 cyl Two Wheel Drive Manual

I have a 96 S-10 with a 5-speed maul transmission. I recently had a new clutch kit (pressure plate, clutch, release bearing. Pilot bearing) and flywheel installed. I know there is a break in period but now when I up shift to 2nd and 3rd I hear some gear grind. If I shift at lower rpms and hold the clutch a second then shift into 2nd or 3rd the shift is smooth or notch with no grind. Could this be my new clutch kit just needing time to get broken in because I had no problems shifting before. Its a hydraulic clutch.
Avatar
Kmcgee69
March 12, 2010.



Any issues with any other gears, or just the 2-3 shift? Also be sure the shop used the correct oil in thetrans when they refilled it. Those came with afew different trannies
The T5 uses Dexron 3 ATF
the NV 1500, 3500 use GM synchromesh fluid
the NV 4500 uses uses GM GL-4 Trans fluid
Also note the NV 1500 should have a GM friction modifier added.
Does the clutch pedal travel feel correct? It isnt going down too far before you feel the hydraulic pressure?

Tiny
Jack42
Mar 12, 2010.
Ive only noticed it in 2nd and 3rd

Tiny
Kmcgee69
Mar 12, 2010.
Be sure the correct fluid was used. There are no shifter adjustments or anything like that, so it may be internal in thetrans, like a synchro that is worn. The clutch shouldnt need to " break in" for just one shift like that

Tiny
Jack42
Mar 13, 2010.
I meant shifting into 2nd and 3rd gear(from 1st to 2nd-2nd to 3rd). The past couple of days however I have noticed both shifts becoming smoother. I haven't heard anymore grinding noises. I'm hoping everything is good.

Tiny
Kmcgee69
Mar 16, 2010.
Hopefully.

Tiny
Jack42
Mar 16, 2010.