Mechanics

CHEVY ROUGH IDLE, 4.3L V6 TBI

1989 Chevrolet S-10

Engine Performance problem
1989 Chevy S-10 6 cyl Two Wheel Drive Automatic 72000 miles

I GOT THIS S10 I PAID 450 FOR IT. NEEDED A LITTLE WORK BUT THE ISSUE IT HAS I CANT FIND THE CAUSE OF. IT HAS A ROUGH IDLE. I DID THE FIRST TUNE UP ON THE TRUCK. BUT PLUGS WERE CLEAN STILL REPLACED SENSE THEY WERE ORIGINAL 89 PLUGS. REPLACED IDLE CONTROL MOTOR. CLEANED TBI. HAS CAT CONV CHECKED. SHOWS 3PSI. I KNOW IT NEEDS REPLACING. FUEL FILTER REPLACED. NO VACUM LEAKS. FUEL SEEMS TO BE SPRAYING INTO THROTTLE BODY NORMAN. WEN U COME TO STOP LIGHT IN GEAR IT IDLE BAD AND ACTS LIKE WANTS TO DIE. BUT NEVER DOES. ONCE U GIVE IT GAS ITS FINE, HAS TONS OF POWER. GETS VERY GOOD GAS MILAGE TO AROUND 20-23MPG, I WAS TOLD THE ECU TEMP SENSOR CAN CAUSE SOMETHING LIKE THIS IF IT BAD AND O2 SENSOR. NOT REPLACED EITHER. IS POSSIBLE TO TEST THEM? IF SO HOW WOULD I? TIMING IS CORRECT ALSO. NO OIL LEAKS. NO OIL IN WATER OR WATER IN OIL. EXHAUST SEEMS TO HAS A LITTLE STRONG ODER TO IT. BUT NOT LIKE A FLOODING OUT SMELL. I DONT KNOW ABOUT THE EFI STUFF. OLDER CARS I CAN FIX. CAN U GIVE ME SOMETHING TO MAYBE HELP ME ON MY ISSUE?
Avatar
Jasoninnorman
October 14, 2008.



Get a timming light hook up run engine shine light on injectors observe spray pattern shoulbe smooth 360 pattern. If you see drips inj bad dirty whatever fuel puddles dose not vaporize low rough idle.

Docfixit
Oct 14, 2008.
Well I replaced the o2 sensor and well I couldnt get it out had to take to muffler shop b/c needed a tourch to heat it. But I drive it there with o2 sensor unpluged and it ran almost perfect. That more or less blew my mind. Never seen that happen before. Do u have a idea on wat or how that can hapen or wat cause that one? Wen got new one pluged in and it started running rough again. Im just so lost. Let met know if u have a idea about it. Ill try the timming light with ingectors.

Tiny
Jasoninnorman
Oct 14, 2008.