Mechanics

CHEVY 97 WILL NOT START AFTER REPLAI

1997 Chevrolet Cavalier

Engine Mechanical problem
1997 Chevy Cavalier Front Wheel Drive Automatic

First, I have a 1997 Cavalier RS, automatic, 2.2 engine. The car has the PASSLOCK anti theft system (original, not Passlock II).

Key Points:

*Replaced PCM & Engine Wiring Harness
*No OBD II Trouble Codes
*Anti-theft light stays on steady, does not flash
*Fuel Pump does not come on
*Cranks, does not start

Details:

I had trouble almost a year ago with the PCM/Engine computer, and bought a new one from Autozone - they ofcourse sent it out to have it flashed for my specific VIN. After replacing the PCM, and doing the " Turn the ket for 10 minutes, then start" thing, it started, and everything was great!

Until one day, driving down the road, the PCM literally fell out of the car, and was ran over, twice. =/ This, ofcourse, damaged the PCM, and the engine wiring harness.

(I had the most difficult time ordering a new PCM from Autozone. First, I had one on order, had to borrow a car, and drive 50 miles to pick it up - only to find that the part was somehow not shipped, the order wasn't completed! So. I called another Autzone, in another town, and before going to pick it up, I called ahead, and again. It didn't come in. So, finally. The part came in at the original store, and I got another ride to go pick it up.)

The PCM was hooked up, along with the wiring harness that I had to buy at a salvage yard (the original snapped when the PCM fell out - and the only place to purchase new is dealership, at around $1200!. So, I had to go with the salvage yard).
The OBD II was reading " P1336", crankshaft relearn required? So. Tried everything, nothing was working. The car would turn over, but not start, not even for a second or two. The anti-theft light would come on - not flashing, just staying on steady.

I then took this PCM back, thinking it may have been defective. This PCM has been hooked up. The OBD II no longer reads " P1336". It finds no trouble codes at all. But. The anti-theft light is still staying on steady. Now, the " check engine" light is also on. And same deal, it turns over, with no start!

The " turn the key to ACC for 10 minutes, try to start" has been tried. I'm so lost.

This is my only car, and it's been sooooo difficult being without a vehicle!

Any advice would be very much appreciated! =)

~Sasha
GypsySunrise24649@gmail. Com
276-807-4616
Avatar
Sunshyne276
July 17, 2008.



Dis you get the second PCM flash programmed with the correct VIN?

Mmprince4000
Jul 20, 2008.
Yes, I had Cardone flash it to my car's specifc VIN. I wish I had some idea what the problem could be. =/

Tiny
Sunshyne276
Jul 28, 2008.