Mechanics

CHEVY VEHICLE SPEED SENSOR

2000 Chevrolet Blazer

Electrical problem
2000 Chevy Blazer 6 cyl Four Wheel Drive Automatic 124000 miles

Intermitent Problem: Speedometer reads zero, ABS light comes on, and Brake light comes on, and the transmission won't shift out of first. All this ponts to one thing: Vehicle Speed Sensor. My question is this, being that it's only happening intermitently, is it more likely to be the sensor, or the wiring. And, how would I trouble shoot the sensor.
Avatar
Evil_jared_mn
March 22, 2009.



Sadly, an intermittent problem is just that. Intermittent.
Unless the car is " broken" while you are testing things, then you cant be 100% sure of the problem.

You have to use the information you read, your experience, and your gut feelings to try to pick the most logical course of action.

Good luck.

Buddycraigg
Mar 23, 2009.
Just for fun, do you have access to a wiring diagram of that circuit?

Tiny
Evil_jared_mn
Mar 23, 2009.
Give me a few hours.
I'll have to get it from a different computer.

Buddycraigg
Mar 23, 2009.
OK, I got the problem figured out. I went to the junkyard and got a used vss for $20. There's a leak at the transfer case rear output, so I replaced the seal and topped of the fluid. Took her for a test drive and didn't see the fault reoccur. Thanks anyways.

Tiny
Evil_jared_mn
Mar 23, 2009.
Sorry, I didn't get the schematic up last night as I said I would.

Good luck with the used VSS fixing the problem.
With the problem being intermittent, you really wont know if you fixed it, but time will tell.

Buddycraigg
Mar 24, 2009.