Mechanics

CHEVY CHEVY 2WD 4.3 ROUGH IDLE

1997 Chevrolet Blazer

Engine Mechanical problem
1997 Chevy Blazer 6 cyl Two Wheel Drive Automatic 246000 miles

This is my wife's truck, she has had an issue with starting, she has to turn the key twice for it to start if it has been sitting overnight. (Fuel pump? Check Valve? Fuel Pressure Regulator?)

Yesturday she complained about a rough idle, in or out of gear it idles realy rough. Service engine light came on (I am not sure when) Error Code P0171, P0174 and P0300. Lean banks and Multiple Misfires.
I did check for Vacuum leaks and cleaned the MAS as well as replacing the Idle Air Control Valve today. Still idles rough like it is missing.
Avatar
TomAClark
May 20, 2009.



Ok what you need to do is find out what the fuel pressure is. Also how old is the fuel filter if it is more then a year old it needs to be changed. Let me know what the fuel pressure is and we will take it from there.

Racefan966
May 21, 2009.
The fuel filter is less then 6 months old. I don't have a gauge to measure the fuel pressure, I guess I may as well take it in to a pro.

I replaced the Air Idle Control Valve and cleaned the MAF sensor and it ran better, but it clearly did not solve the problem. The motor seems to be missing at idle and though the computer says it is running lean I am pretty sure I heard a couple of small backfires from the muffler.

I found a leak in the radiator as well, drivers side tank between the top water house and the oil cooler line had a horizontal crack. My buddy at the radiator shop says that year model cracks in the same place everytime. I am glad I found that crack when I did, an old pal of mine lost a dog who got coollant on his paws (which he then licked off).

If I had the truck at home I may just beg, barrow or steal a fuel pressure guage, but I am stuck 40 miles from home with only a handful of tools and I need to get back to work and earn some money.

It is only about 3-4 miles to the radiator shop, I will just have someone I know is honest fix the radiator and then have someone that may buddy can recommend look at the other problem.

Thanks again

Did any of you guys ever do any mods on IH Scouts?
I am gonna need some Scoutheropy this weekend.

Tiny
TomAClark
May 21, 2009.
Ok I have thought about your codes and I would say if you can check the coolant temp sensor and the cap and rotor you just might find an issue. If you have digital multi meter then just unplug the temp sensor and do an ohms test of the sensor (not the wire harness) and if you do this when it cold then get back to me with the ohm readings and the air temp at the time of the test. Now as for the cap and rotor this style of cap has an issue with corrosion so pull it and check it. Let me know what you find. As for the anti freeze killing animals if you are conserned about that then use the serria anti freeze it may make and animal sick but won't kill them.

Racefan966
May 22, 2009.