Mechanics

97 ACHIEVA STARTS THEN DIES AND WILL NOT RESTART FOR 24 HRS.

1997 All Other Makes All Other Models

Head rebuilt on the car and reinstalled.
I started the car 2 times, each time it ran for only about 5 seconds then died. I was not able to start it on a third and fourth try. (It turned over though). The next day the same starting pattern happened. Again the same on day 3.
I checked fuel and injectors are shooting about a half thimble full of fuel as I turn the car over 4 or 5 times. How much should I be getting?
It also is firing. I sprayed WD40 into throttle body and the engine fired it.
Dealer told me to suspect passlock system. Could it be this that is shutting the fuel down? Passlock light is on solid now 1/5/07.
1/6/07 - I have used a code reader - no codes found.
The car started 1/7/07 and it ran well for 10 seconds and then died. I still suspect no fuel to injectors. I left the battery connected for 24 hours and the passlock light which had been on is no longer on.
Next step is to replace fuel filter and check fuel rail at the engine.
Please write back with ideas.
Avatar
Vcarrier
January 5, 2007.



Try checking the fuel pressure might lead you to the pump/pressure regulator and also the pump relay

Also you could try the crankshaft position sensor

Rasmataz
Jan 10, 2007.
Is there a preferred location or port to check fuel pressure on the 2.4 twin cam?
I will check things in the order that you suggest. : )
Can you suggest a procedure for checking the cranshaft position sensor? Can I get a meter from Autozone to do this?
I appreciate the quick reply.

Tiny
Vcarrier
Jan 10, 2007.
Do you hear the pump come On for 2sec

Rasmataz
Jan 10, 2007.
Yes, the fuel pump does come as soon as I turn the ignition switch to on position. I would say it stays on at least 2 seconds.
I did try checking the amount of gas I got from each injector when I cranked the car 4 or 5 times. I got about 1/8 a thimble full of fuel.

Tiny
Vcarrier
Jan 10, 2007.
The shrader valve should be within the fuel rail-at the CPS disconnect and check the 5vRef.

Next time you get it running and lose it-immediately check for spark to include the fuel pressure.

Is the fuel pump On for that 2sec-try this hard wire the pump and see what happens to rule out the relay

Rasmataz
Jan 10, 2007.
Is this a TBI or MPFI?

Find the CPS check its connection-Do you have spark

Rasmataz
Jan 10, 2007.
[i: 27119f4a54]Is this a TBI or MPFI?

Find the CPS check its connection-Do you have spark [/i: 27119f4a54]

Not sure what you are referring to. TBI or MPFI
and CPS
yes I do have spark because it does start and then it acts like its running out of gas.

Tiny
Vcarrier
Jan 10, 2007.
TBI Throttle Body Injection
MPFI: Multi Point injection
CPS: Crankshaft position sensor

The CPS can go whack on the 10sec interval

Try this crank the engine over for atleast 10sec the pump should operate within the time. If not consider the the relay. Don't think computer yet.

Find the pressure regulator disconnect the vacuum hose check for fuel-if present the regulator is gone.

Rasmataz
Jan 10, 2007.
Fuel pressure is a very critical issue-My last advice is check the pump, am hinting on it. Sometimes pumps behavior can be a bear to diagnose.

Rasmataz
Jan 10, 2007.
OK, I have 4 injectors. Is this MPFI? I have a butterfly on intake manifold which I thought was a throttle body.
OK, I will check the fuel pump output pressure by attaching a pressure guage at the fuel rail somehow.
My earlier comment regarding the amount of fuel I got out of each injector (1/8 of thimble with 4 or 5 cranks), is this too little fuel?
Thanks again.

Tiny
Vcarrier
Jan 10, 2007.
Page 1 of 2