Mechanics

93 COROLLA, SPEEDOMETER NOT WORKING CORRECTLY

1993 All Other Makes All Other Models

Hello experts! I have a 93' Corolla which the speedometer doesn't do anything till I hit about 40 mph at which then it will shoot to needle to the 60mph markings. I changed the cluster and the results were the same. The odometer and tripometer work perfectly. THanks in advance for the help!
AD
Avatar
Lashark
December 23, 2006.



Try the vehicle speed sensor at the tranny

Rasmataz
Dec 23, 2006.
Any idea if this is a difficult part to replace? I assume it needs to be replaced from under the car. Thanks for the quick reponse

Tiny
Lashark
Dec 24, 2006.
Mine is doing the exact same thing. Seems to have coincided with replacement of a dead alternator, but the two problems may be unrelated. Alternator has been replaced but the speedo does EXACTLY what yours is doing.

Tiny
Gkroper
Jan 3, 2007.
I am in the process of getting the speed sensor replaced, used part off of EBAY since this part is nearly $200 new. Will let you know if this fixes the problem. Thanks!

Tiny
Lashark
Jan 5, 2007.
Take it out-make sure its connected, cleaned-then turn key to On position and spin it-the speedometer should fluctuate, any wiggle will do-indicating its still good. No fluctutation= VSS or wiring problem, you might also have another one in the speedo head. Put it back in make sure its line properly and all the way in. Road Test.

Good Luck!

Rasmataz
Jan 5, 2007.
This was a job I won’t soon forget. I was unable to get the speed sensor out. Up about a quarter of a inch a best. So I just replaced the head of the full sensor unit. This is the piece that contains the circuit. Same results, bad speed readings. Had a buddy with one of the diagnosis units which indicated the sensor was reporting correctly. Actually had to drive with the diagnostic unit on my lap. I tried a different cluster unit with similar problems. Road Test, I think your assessment is correct, there must be wiring issues between the cluster and the sensor since the sensor must be giving the correct reading for the diagnostics to report the correct speed.

Not sure how to handle the wiring bit.

For those of you looking for where the speed sensor is on the 93 corolla, it is on top of the trans behind engine. Almost a perfect 12 o’clock position if you are standing in front of the car. You can only see it working for the right side of the hood.

Tiny
Lashark
Jan 6, 2007.
Ok, since I am convinced that my speedometer problem is not the Speed Sensor and most likely not the Cluster that it must be the wiring. Since the diagnostics retrieved the correct speed readings, I can eliminate the wiring from the speed sensor.

So, this leaves me with the wiring from the cluster to wherever the hell it goes. Does anyone have suggestions to replacing/testing this portion of the wiring. I know very little about cars so be easy on me with the terms.

Thanks!

Tiny
Lashark
Jan 8, 2007.
Here's the VSS configurations: 1. From tranny or transaxle Vss to ECM
2. &Quot; tranny or transaxle thru combination meter Vss to ECM
3. &Quot; tranny or transaxle Vss thru combination meter to ECM
4. From Wheel Speed Sensor to ABS computer thru combination meter to ECM

PCM/ECM/ECU=The Computer

Rasmataz
Jan 8, 2007.
Are most ECU's located behind the dashboard? I am hoping it is just the wire between the cluster and ECU. Sounds simple, I think

Tiny
Lashark
Jan 8, 2007.
Not really familiar with that model-you said earlier you can track it with the scantool. Do you have a manual cause they are different configurations on how the speed sensors are wired and how many involved. I hope am right, you're looking for a Brn and white for the signal wire and a brown for a ground-that's coming from the speed sensor-dunno from the cluster to ecm might change color from there.

BTW how did you check the sensor-that you're getting the correct speed.
AD

Rasmataz
Jan 9, 2007.
Page 1 of 2

AD