Mechanics

ENGINE SEEPS OIL OR SOMETHING AND MECHANIC

1994 Acura Vigor

Engine Performance problem
1994 Acura Vigor 4 cyl Four Wheel Drive Automatic 195789 miles

I bought a car off craigslist and I am not sure if something is wrong. The main problem is it occasionally smokes(white) off the top of the engine, and smells bad, like burnt chemicals. I had a new raidiator put in because it was overheating. That is not the problem, I think, the smoke is coming from the passengers side, as well as it feels hot. The mechanic said it was oil, but that it was not a major problem. I just want to know is that true? Or should I pay them ALLOT of money to pull the engine out to see where it's coming from. It only does it after it has been running for a while, and more when it hasn't ran for a few day's. It also stalls when I come to a srop, or about to take off from a stop. I am HOPING it is because it has been sitting for a while and it just needs a tune-up or something. I put the fuel injection cleaner in the gas tank, but I am not sure if it is something more serious or not. Can you tell me what these two problems may be? Thanks : )
Avatar
Dejavuicutoo
August 3, 2010.




HI there,

If it has an oil leak onto the exhaust, this can smell rather acrid, I would get any oil leaks investigated first, it may be a rather minor problem, as for the stalling this may just be a tune problem, get a scan done to check for any unresolved fault codes and check for any vacuum leaks as well.

Mark (mhpautos)

Mhpautos
Aug 3, 2010.
Thanks for answering. Idk, it comes off the engine, not out of the exhaust. Does that matter?

Tiny
Dejavuicutoo
Aug 3, 2010.
No not out the exhaust, but dripping onto the hot exhaust pipe and burning.

Mark (mhpautos)

Mhpautos
Aug 3, 2010.
I didn't see any smoke in the exhaust, but on the passengers side under the hood. Also, today when I drove it, for the first time it stop having any power while I was driving it, it was on, but no gas power. I pulled off the side of the road, then like two minutes later it was running fine. It has been sitting for a year, so I'm PRAYING that it is the fuel line cleaning itself out, I put in the fuel injection cleaner. But it did have a burnt plastic smell for two seconds, then that same burnt chemicals smell. Could it be the head gasket, even though the temp gage is fine, and It randomly smokes. I really don't know what the problem could be, the mechanic said it was fine. Thank you for taking the time out to answer these question, I do reallly appreciate it.
AD

Tiny
Dejavuicutoo
Aug 3, 2010.

AD