Mechanics

IDLING AND RPM'S ARE WEIRD

1996 Acura TL

Engine Performance problem
1996 Acura TL Front Wheel Drive Automatic 73000 miles

I love my acura even though it is giving me problems to the point of frustration. I love it and want to fix it ASAP.
I have 1996 Acura TL 2.5 and I recently replaced the engine+transmission with engine and transmission from 1998 TL 2.5. There are many problems to be addressed, but the main has to do with idling and RPM's.
When the engine is cold and I start the car, RPM's go straight to 2300 and it stays there for about 30-40 seconds after which they constantly jumping up and down but only up to 1500 RPM the only way to stop this is to disconnect the sensor from air control valve. As soon as I disconnect it, RPM's go back to normal and it starts normally when it is cold. Also, my A/C is not working properly at idle because RPM's fall to 450 and compressor does not have enough strength to work. It is only clicking and RPM's go up and down. Basically it is only working when I am driving and when I stop at the stop light, it starts clicking as if it is trying to do something and RPM's go up and down rapidly until I turn A/C button off or I start moving again.
I don't think that the air control valve is bad because I installed the one from my previous engine and it was working fine before (unless something happened to it when I took it off) and now I replaced it with another one just in case, and it is doing the same thing. I bought brand new Fast Idle Valve that is right next to Air Control Valve and it did not help.
If you know anything about RPM's and idling on this acura, any suggestions will be highly appreciated. I'm very discouraged because I spent a lot of money and problem remains the same.
I have 18 months daughter and my wife is pregnant with another daughter and she is ready to deliver anytime now. This is our only vehicle and we live in California - it is hot outhere.
Avatar
Vadimkaz29
August 2, 2008.



Hi vadimkaz29,

The problem of high cold start rpm and hunting is usually due to vacumn leakage or idle speed out of adjustment.

Check if any vacumn hoses had been wrongly connected or if any are leaking.

Check for clogged coolant hoses under the IAC and fast idle valve.

Was the throttle valve stopper tampered with?

KHLow2008
Aug 7, 2008.