Mechanics

TURN SIGNALS NOT WORKING

1996 Acura Integra

1996 Acura Integra 4 cyl Front Wheel Drive

I recently bought a 96 Integra GSR with 99 GSR motor with some mods. I swapped over to a black interior a couple weeks ago. Meaning Dash board, steering wheel column, all panels, seats, etc. Now my turn signals do not work at all. The hazzards work fine. I have replaced hazzard swith, the turn signal lever on steering wheel, checked fuse, relay clicks with hazards. I have been racking my brain trying figure it out. I have also unplugged front corner turn signals and nothing.

I just rigged up a quick fix by putting 12volts to one of the wires that plug into the steering column turn signal lever. When I press it for the left or right signal, it just ligths up, but does not flash. Kind of like one side of your parking lights working. So I am now manualy tapping it up or down to use my blinker

Any Ideas?

Thanks,
Scott
Avatar
96intergraGSR
June 9, 2010.



Hi 96intergraGSR,

Did you check the integrated control unit? It is plugged into the fuse box.

KHLow2008
Jun 9, 2010.
I'm sure everthing is plugged in. There is 3 pluges from the steering column and all are pluged in.

I will double check later and get back to you.

Can you think of anything else?

Thanks again,

Scott

Tiny
96intergraGSR
Jun 9, 2010.
Hi Scott,

What I meant was to check if the unit is faulty. The turn signal circuit has to go through the integrated control unit as it incorporates a right and left flasher unit.

When replacing all the items, were any part of the wireharness replaced?

KHLow2008
Jun 10, 2010.
Is that a relay on the back side of fusebox? I will have to locate one and give a shoot. I'll get back to you after I try that.

No harnesses were replaced, just unplugged and plugged back in with new dash and steering column.

The only thing I have not done is replace the relay. It does work with the hazzards, so I figured it was good.

I will try to replace the ICU and flasher relay both and hope one of them fixed the problem.

Thanks again,

Scott

Tiny
96intergraGSR
Jun 10, 2010.
Do you have a schematic of the wirings?

Let me know how it goes.

KHLow2008
Jun 11, 2010.
That's a no on the schematics! I have the wires figured out to a point. I did car audio for 10 years.

If you have access to it and think it might help, you can send my way for sure.

There is only 3 wires it the wiper control. Left and right rest at ground and the other is open curcuit. I ran 12 volts to the open curcuit wire and when I hit the turn signals it just stays on perm. With no flash. I'm just manually click it up or down to use turn signals right now.

I'm going to try and find spare relay and ICU this weekend.

Thanks,

Scott

Tiny
96intergraGSR
Jun 11, 2010.
I have emailed you the schematics for the exterior lights, hope they are helpful.

I could not email the files to you due to the fiollowing. Do you have any other email that I can use?

The following addresses had permanent fatal errors

KHLow2008
Jun 18, 2010.