Mechanics

CHECK ENGINE LIGHT CAME ON AFTER TUNE UP

1993 Acura Integra

Engine Mechanical problem
1993 Acura Integra 4 cyl Front Wheel Drive Automatic 176000 miles

I just did a tune up (plugs, wires, cap and rotor). After taking everything off and replacing started the car up and the idle goes up to 1500 rpm's where before it was always at 1000 rpm while in park. It goes up to 1500 then down to 1000rpm then back up to 1500 and stays. Once it goes back up to 1500 rpm the check engine light comes on and stays on. Then where the park, neutral, drive, S3, S4 lights are in the dash the S3 light comes on and continues to blink.

I should mention that when taking the old plugs out the 2nd and 3rd plugs were extremely hard to get out. They were extremely tight.

Took it for a test drive around the block and the check engine light and S3 light stayed on the whole time. Came home parked it turned it off and then turned it back on and now the lights are off.

Any ideas?
Avatar
Mesaredhead84
April 9, 2009.



Check engine light being on means the computer has identified a problem within the engine management system-you need to get it scanned for code/s this is your starting point. Or you can try cleaning out the idle air control valve and see what hapeens

Rasmataz
Apr 9, 2009.
Is there a reason why it would go off after driving it? Did it just need to get used to all the new stuff and reset itself? Now it is off and it drives fine. I drove it again after letting it sit for a few mins and now it is fine. Any suggestions?

Tiny
Mesaredhead84
Apr 9, 2009.
I just did a tune up (plugs, wires, cap and rotor). Its got nothing to do with this. Get it scanned for code's and comeback with it and I'll continue to help.

Rasmataz
Apr 9, 2009.