Mechanics

99 CROWN VIC COOLANT TEMPERATURE SENSOR BROKE OFF

1999 Ford Crown Victoria • 101,000 miles

I don't know if I can just buy a replacement or what but it popped off but I can't tell I te threads are going to hold a new one. What should I do where do I begin?


Avatar
Mdwelmwood
April 23, 2013.



It looks like tits cracked where I've pointed all you can do is try otherwise another manifold. But they shold be plentiful in junkyards.


Hmac300
Apr 23, 2013.
I also have this problem except mine doesnt look cracked. I have used jb weld original to repair it but it keeps coming off. Is there something I can do to fix this. It blew off a few weeks ago and has broken through the jb weld twice now. I really don't have the money for a new manifold but if that is what is needed, I will do it. Can anyone help me?


Tiny
Loganacorliss
Aug 14, 2013.
The only thing I can think of is to clean all the crap off around it and try epoxy. It may or may not work but you need to let it set up for at least 20-30 minutes after you put it in. Of course there is not guarantee that this will work. You can also try to find a used manifold as well.


Hmac300
Aug 14, 2013.
Im doing that now. It looks to me like the nut that the temperature sensor is bolted to has no threads left on it and when the temp sensor came out, the nut came out screwed into it and not the manifold. I guess I will just buy a new manifold and temp sensor instead of doing it the cheap-crappy way.


Tiny
Loganacorliss
Aug 14, 2013.