Mechanics

ENGINE HASITATES AND BUCKS

2008 Volkswagen Polo • 10,000 miles

Hi, my cars keeps "jolting" as I accelerate to aprox 30mph then yesterday it lost complete acceleration, however the rev counter was still working and it drove again after restarting the engine, though the jolting continued and it cut out twice more, a light has appeared on my dash but I havent yet looked in the manual as it is elsewhere, does anyone have any suggestions as to the fault? Any advice would be appreciated. Thanks, charlie.
Avatar
Charlieb87
December 29, 2011.




Do you have a check engine light? Sounds like a hesistation problem

Could be caused by one of the following below

Oxygen sensor.

Catalytic converter.

Fuel injectors dirty/sticking.

Mass airflow sensor/Airflow meter.

Throttle position sensor.

Crankshaft position sensor

Knock sensor

Manifold absolute pressure sensor.

EGR Valve

Fuel pressure regulator leaking or defective fuel pump.

Fuel contamination.

Foul/defective spark plugs.

Open spark plug wires.

Ignition coil/Coil packs defective.

Incorrect ignition timing.

Cap and rotor.

Note: If it doesn't apply disregard it and keep testing.

Tiny
Rasmataz
Dec 29, 2011.
Thanks for your reply, I do have what looks like an engine light appear on my dash. The car is just over 3 years old and the warranty has therefore just expired however it has had a service and its first MOT in october, should the parts be covered by these?
AD

Tiny
Charlieb87
Dec 29, 2011.
Scan the computer for code/s

Tiny
Rasmataz
Dec 29, 2011.

AD