Mechanics

ONLY GOES IN 1ST AND FOURTH GEAR SOMETIMES WHEN I START IT THEN USUALLY DOESNT AGAIN WHEN I TAKE OFF FROM NEXT STOP

2008 Hyundai Santa Fe • 63,000 miles

Tech. Changed input and output speed sensors and map sensor and still doesnt run right check engine light on something electronical but what could it be its automatic notice gears on dash through the shiftronic
Avatar
Squril
October 14, 2012.



What is the code number?

Rolling over gears could be electronic but we need the code

Roy


ASEMaster6371
Oct 14, 2012.
Code cam up output sensor again but now it has to be deeper tech changed input and output sensor brand new


Tiny
Squril
Oct 15, 2012.
We need the EXACT code number, not just the description.


KHLow2008
Oct 15, 2012.
Before the output and input sensor and map sensor were changed the codes were p0722 and p1107. Any chance you can be the trans fluid sensor I seen a guy online have almost the exact same symptoms and the tech told him it was the trans fluid sensor does that make sense


Tiny
Squril
Oct 15, 2012.
A code does not necessarily mean a bad sensor. Any loose connections with wiring, broken wires or a bad PCM can be the cause.

P0722 - Output Speed Sensor Circuit, no signal.
P1107 - MAP sensor short or intermittent low voltage.

For both problems it could be the wirings that is at fault. Any loose or contaminated connections can cause that.

After replacement of the sensors, are the trouble codes the same?

The MAP sensor should not affect the transmission shifting but can cause erratig idling, stalling or difficult starting.


KHLow2008
Oct 15, 2012.
P0722 only came up for output sensor after install


Tiny
Squril
Oct 15, 2012.
Recheck the sensor and its connector. Ensure the wires are not broken as they can be brittle and removal installation can break.


KHLow2008
Oct 15, 2012.
I had a technician do it is there anyway I can look under the truck to see where the sensor and wiring is, or is it too hard to get to , and I need to take it to a tech. Again


Tiny
Squril
Oct 15, 2012.
It is not too difficult to get to but you might need to remove the battery and air cleaner.


KHLow2008
Oct 15, 2012.
Do you think that most likely my problem or still other possibilities? Here I thought the sensors were under the car


Tiny
Squril
Oct 15, 2012.
Page 1 of 3