Mechanics

ANY OTHER PLACE TO CHECK-BATTERY LIGHT ON AFTER NEW ALTERNATOR(BEARINGS DIED) AND NEW BATTERY

2007 Jeep Compass • 100 miles

Car died--grinding noise, battery light, engine system lights. Alternator bearings. Replaced alternator(due diligence before re-assy). Battery 12.7V -good- Started car, dropped to 11.8V--battery light and engine light on. No voltage at post of alternator. Checked all fuses in TIPM box. Battery drops to 12V when in access-mode). Replaced battery. Still batt and engine light. No burnt wires or connectors on alternator hook ups. Simple replacement. Whate else is there? Fuselink? Where? Relay? Where? IS there something hidden on this vehicle?
Avatar
9000compass
March 6, 2012.



Look in the underhood fuse box. There is a heavy fuse, maybe 100-120 amp. It is the power for the heavy wire to the back of the alternator.

Roy


In the fuse box? Must be another location or underneath because I think I checked everything in the box using an ohmmeter. I guess this is what serves as a fuesable link? I love this--2 weeks after the warranty expired--like clockwork. If you can lead me I can follow. (And aside-Anywhere online I can get a charging system layout for this?)


Tiny
9000compass
Mar 6, 2012.
Check this schematic. It shows a link between the starter and the alternator.

Roy


Information makes things so simple. I took one look this morning at the starter, saw the alternator cable, and verified that the fusible link was indeed, fried. I verifed the cable with the ohmmeter. Took 5 minutes. I tried to bypass directly to the battery positive BUT battery light and engine light in car still come on voltage is still 11.8V indicating no charging(do I really need to rev up to 2500RPM's).

Am I missing something else? Powertrain Control Mod at the Field control and Gen Sense?? It still starts well and revs well.

I know the Dealership vampires are foaming at the mouth if this turns into a $1000 plus adventure if I fail. The $6 140AMP fuse has a shipping cost of about $25.00(total $31.00).

Thanks for the wiring layout and your help.


Tiny
9000compass
Mar 7, 2012.
Ok, first I would remove the new alternator and have it checked to verify that it did not frie the link. There are times we get bad new parts.

Roy


I just wanted to give you an update. Your information has been very helpful.

So far so good. Removed the ALternator(40 minutes) and ADAVANCE AUTOPARTS had the correct attachment to test it. Turned out to be good. Cable is 10gauge, purchased 14guage Fusible linkwire. Just waiting to remove starter to attach link then reinstall everything and try it. When completed I will reply again when just to update you. Thank you again.


Tiny
9000compass
Mar 12, 2012.
Good luck

Roy


ASEMaster6371
Mar 13, 2012.
SUCCESS! This morning I went out, removed starter, wired fusible link wire(14ga), reassembled, rechecked connections(due diligence), started it up, and every light went off on dash board except engine light. I drove vehicle for abut 3 miles, shut it down, went to work, started it again in 3hours and the engine light extinguished itself.

Thank you so much for your help, your patience, your wisdom. Can I suggestive sell the website? I already told one person who has a Patriot who is interested --IF they have a problem.

Thanks again


Tiny
9000compass
Mar 13, 2012.
Thanks for the feedback. Let us know if we can help you again

Roy


ASEMaster6371
Mar 14, 2012.
2007 Jeep Compass about a month ago started hearing grinding. No indicator lights no problems with performance. Yesterday got louder and this morning batt light came on added water to batt started the car waited a while turned it off tried to start again all indicator lights remained on and car would not start. Would not even crank. I thought it was alternator but then waited lights came on security system works radio works. Could this be the starter?


Tiny
Sbuchanan442
Mar 14, 2012.
Page 1 of 2