Mechanics

HUMMER H2 STARTER PROBLEM

2007 Hummer H2 • V8 AWD Automatic •

When I hit the brakes the parking lights come on also when I turn on the left signal with lights off all the other lights also flash aswell but they are dim when the lights are on and I put on the left signal it comes on my dash but it does not flash at all but the right side flashe is working properly. Pls help.
Avatar
07hum
March 12, 2011.




It sounds like there is a possible issue with corrosion, an open fuse, or shorted socket. Does it have trailer light wiring that has been installed, anything other than factory, that could cause miscellaneous issues. There is also a junction block under the rear, near the center of the bumper that can have problems with connections/corrosion, most of the lighting circuits for the rear pass through it.

Factoryjack
Mar 12, 2011.
Well the truck came with the factory hitch I did check the junction box in the back it seems to be all ok.
What do u mean about an open fuse and how would I check for that?
Also noticed my car starter shuts down when parking lights turn on stating a fault code that the brakes were applied?

Starter has been in car for over 2 years now.
AD

Tiny
07hum
Mar 12, 2011.
Did some reading and noticed allot of people get all lights flashing due to flasher module is that possible?

Tiny
07hum
Mar 12, 2011.
The flasher module is a possibility. Not sure what is meant by the starter shutting down, and a fault code stating brakes applied. I am not sure at this point, why the park lights would disable starter.

Factoryjack
Mar 14, 2011.
Well changed flasher module $130. Still doing the same thing right side flashs no problem left side turns on all my parking lights as do the breaks when I hit the pedal.
Also when lights are switched on left signal does not work at all please help as this is the only car I have to drive right now.

Tiny
07hum
Mar 14, 2011.
Well got down to pulling bulbs and fuses ends up being the back left bumper light the socket was fine but the plug side was corroded
had to cut cplu entirely off and everything is working fine including car starter. Now called dealer no part number for that light socket isnt that great was told to come in to match it up !

Tiny
07hum
Mar 14, 2011.
Was there water in that lamp? That is a common problem, and the lamps have been redesigned to eliminate the vent that the original lamps had. I am not certain if that socket is serviced as a seperate part.

Factoryjack
Mar 15, 2011.
No water in lamp just were it plugs to the actual socket that holds the bulb I unpluged the socket but noticed the wire getting warm so the harness that plugs into the socket I had to cut off the pins had corroded. So what I did was take out the other side and im going to order a delta lightkit for it I think I would get more usage out of them than marker lights not like the h2 needs anymore markers. Lol. Thx for u help gstacy glad to see theres still honest people out there !

Tiny
07hum
Mar 15, 2011.
You know that those are not just park lights, they are brake lights as well. Just an FYI for you, prior to installing aftermarket. Bear with me, in the fact that I am not familiar with a delta light kit, and it's application here.

Factoryjack
Mar 15, 2011.

AD