Mechanics

I WENT TO HAVE THE EMISSIONS TESTED. THE ATTENDANT SAID THE PLUG WAS BROKEN AND HE COULDN'T TEST IT. HOW CAN I REPAIR IT?

2006 Buick La Crosse • 40,000 miles

It is loose, out of the bottom dashboard. I don't know how it could have been broken.
Avatar
1lkt
March 28, 2012.



So did the plug just fall down off the dash or did the wires break also. Can you post a picture of the plug?Iam flying blind here.


Saturntech9
Mar 28, 2012.
The first time I knew there was a problem was when the epa tester told me it was dangling and he couldn't test my car. The wires don't appear to be broken. Thanks for any help.


Tiny
1lkt
Mar 28, 2012.
Hi guys. Sorry for butting in here but I couldn't help myself. Tell that sorry tester to use two hands to connect the plugs together. Broken mounting tabs have nothing to do with emissions. If he can't be bothered to use common sense, plug the connector in for him, then feel sorry for him. That's probably as high in life as he is going to get unless he becomes a politician!

You'll notice the plug isn't even broken. It's the plastic dash cover where it was clipped to that is broken. Ask him what he does when a car comes in with a real problem? Better yet, ask him what he would do if that happened on HIS car.


Caradiodoc
Mar 29, 2012.
Great point cardiodoc is correct the plastic part of the dash where the connector slides in is broken.I dont see ethier how the car could fail from not have the obd2 connector mounted makes no sense.I would ask to see that in writing that it fails for not have the connector not mounted.I know if it cant link it fails but for not being mounted that is just none sense. You must have caught him on a bad day.


Saturntech9
Mar 29, 2012.