Mechanics

KIA SEDONA SENSOR PROBLEM

2005 Kia Sedona • 98,000 miles

Replaced the crankshaft position sensor. Nnow the engine runs hot by about 500 to 1000 rpm and wont shift when driving. Sounds rough. Is there an adjustment for the sensor or is there something else im missing?

thanx
Avatar
Drewblud
February 19, 2013.




So you have a high idle by 500-1000 rpms?ALso did you have a code is that why you replaced the sensor?If you had a code what was the number?Any current codes now?

Saturntech9
Feb 19, 2013.
Car died at a light. Code read as po337-replace crankshaft sensor. Replaced sensor and reset check engine light. Now there are no codes. Main problem now is that it wont shift out of first gear.

Tiny
Drewblud
Feb 19, 2013.
What is the make and model of the scan tool your using to read codes?Also does the car have a lack of power?
AD

Saturntech9
Feb 19, 2013.
Make is "actron"
model is "cp9135"
serial is "243933"
seems to run a little hot at idle. Usually runs at 1100. Now runs at about 2000. Drives ok til about the time it should shift then either wont shift or seems to shift and looses power. Will not shift into drive at all.

Tiny
Drewblud
Feb 19, 2013.
?

Tiny
Drewblud
Feb 19, 2013.
A lot of the cheap generic scan tools sometimes won't read all the transmission codes.I have Mitchell on demand online repair info and there isn't much detail on the kias. For diagnoses or repairs so the car drove and shifted normal before you changed the crank sensor?Also you said the car won't shift at all into drive so it will physically shift into drive but won't move when you hit the gas?Or just stays in first and won't shift?

Saturntech9
Feb 19, 2013.
Shifter physically goes into drive. Car starts out fine then wont shift past first gear.

Tiny
Drewblud
Feb 22, 2013.
If it didn't do it before changing the crank sensor sounds like something went really wrong. Does it havea lack of power like the engine is bogging down?

Saturntech9
Feb 22, 2013.

AD