Mechanics

CLIMATE CONTROL

2005 Ford Territory • 6 cylinder 2WD Automatic • 65,000 miles

Just yesterday after towing a trailer (empty) the entire Climate Control system shut down. When I start the car, all I see is the air recycle logo flash on the instrument panel (picture attached). No other information is on the screen apart from the radio and trip meter. I'm not sure what is wrong, as the A/C was working perfectly when going to pick up the trailer, and even on the way back. It just stopped working when I took the trailer off the back of the car, and drove the car back into the garage. I tried to press all of the climate control buttons to turn it back on and nothing seems to be working. I've also checked the main fuses, but they all seem to be OK also. Also, after removing the trailer plug from the car, coincidently the reversing sensors no longer work. Normally when the trailer plug is inserted, the reversing sensors are deactivated, but it would seem the trailer plug is still inserted.
AD
Avatar
Burdo
December 30, 2010.




Hello, can I cancel this request. I have fixed the problem myself, which was the airbag fuse. Sorry for the inconvenience.

Tiny
Burdo
Dec 31, 2010.
Glad to hear you found it. Come on back if you have any other issues.

Wrenchtech
Dec 31, 2010.
Hi our ford territory tx 2005 model has had the same problem yesterday could you please tell us where the air bag fuse is located.

Thank you
AD

Tiny
Julieanne8699
Jan 2, 2011.
Please disregard above comment we have fixed it now it was the reversing lights fuse.

Thank you

Tiny
Julieanne8699
Jan 2, 2011.
No worries. It's a bit tricky to find, as the airbag or reversing lights have absolutely nothing in common with the A/C or the climate control. I only found it by by pulling out each fuse and checking them individually.

Tiny
Burdo
Jan 2, 2011.
Closing out question

Wrenchtech
Mar 11, 2011.

AD