Mechanics

CHRYSLER PT CRUISER ENGINE PROBLEM

2005 Chrysler PT Cruiser • 95,000 miles

Lopes or cuts out around 3500 rpm, in neutral and in drive. Any ideas? 2.4 non turbo.
Avatar
Guest
January 31, 2013.




Do you have any codes? Have you checked for codes?

Saturntech9
Jan 31, 2013.
Did have 2 codes, p0132 and p0138. I replaced both oxygen sensors, that got rid of the codes, there are no other codes.

Tiny
Fritus
Jan 31, 2013.
Have you checked for a plugged cat?

Saturntech9
Jan 31, 2013.
No but I will right now.

Tiny
Fritus
Jan 31, 2013.
What next?

Tiny
Fritus
Jan 31, 2013.
Have you checked the spark plugs etc yet?

Saturntech9
Feb 1, 2013.
Yes. I also put a gauge on the fuel and it read 40lbs. I guess it should be 50 to 60. Do you think that could be the problem?

Tiny
Fritus
Feb 2, 2013.
So you back pressure tested the exhaust and that checked out? Also so while your driving above 3500 the engine cuts out or the transmission is slipping?

Saturntech9
Feb 3, 2013.
No, I did not do that. And it is definately the engine, not the tranny. By back presser you mean, put my hand over the exhost and tell it to cough? Or is there a reading of some type tthat I need to get? Or change in idle, or leaks, or? This back pressure bit ive never done. And before I forget, thank you verry much for your time. Im sure theres other people that also need your help as bad as I do.
AD

Tiny
Fritus
Feb 3, 2013.
No a back pressure test is done with a back pressure gauge in the exhaust pipe.

Saturntech9
Feb 3, 2013.

AD