Mechanics

CODES C0561 & U2100

2005 Chevrolet Cobalt • 100,900 miles

Reading codes C0561 and U2100, b4 it read P0101 we clear it but still that same codes, I have already replace the MAF sesnor 2 times, also had a P0172 replace the Bank1 oxygen sensor and also replace the coolant sensor after a week or the code 0172 went away and now I get C0561 and U2100, I know it has to do with EBCM/BCM. Some advice b4 I take it to the dealer, no ligths on the DIsplay. Like ABS or Traction appear.
Avatar
Miltongina
July 8, 2013.



The c0561 has shut down your traction control due to an error, the u2100 may be the cause which gose into lan control and bus connectors. So have dealer look at it


Hmac300
Jul 9, 2013.
Thanks for the advice, I get the reaing from the OBC Scanner but I dont get a ABS/Traction ligth on my DASH, can this error be cleared by the dealer or can it be done another way. Is running the car dangerous?


Tiny
Miltongina
Jul 9, 2013.
It's doing that because of the one code there is a loss of communication due to the other code and your traction control has been turned off. Kinda hard to explain but the dealer can sort itout for you


Hmac300
Jul 9, 2013.
Thank you for ur good advices. Now after a few days I get another CEL again, took it to Autozone
Again and this time it came up with a P0171 code, did some reading could be MAF dirty or malfunction, I had already replace it about a month ago, I have not tried the Fuel FIlter yet cause I have not change it since I got the car about 2 yrs ago and have not tested yet the fuel pressure to c if I have from 50-60 PSI also going to chk my Intake Manifold for leaks or loosen, dont think is the bank1 sensor already change it about 1 week ago when I got the P0172. I am going for the Fuel filter first and change it, if it coninues with the CEL then test the fuel pressure, Do you think that I am doing the correct processing for the fix of the P0171.

Thank you. Just trying to save money on DIY and learning some more.


Tiny
Miltongina
Jul 11, 2013.
Check the pressure first if it's low just replace the pump and filter. Also instead of replacing another maf look for grommets with holes in them in valve covers an stuff like that or the air duct not seated correctly


Hmac300
Jul 11, 2013.
Your are referring to the grommets were the MAF is inserted, My is black and square with 2 screws to hold it down. I do have a CAI partial with the Air duct on it. Here is Pic of my CAI.


Tiny
Miltongina
Jul 11, 2013.
Grommets on the engine like the valve cover. Also I see you have a K&N filter. If this has to much oil on it it will screw up the maf and give a code so check that. I'd bet that is why you mistakenly replaced the maf.


Hmac300
Jul 11, 2013.
Yeah I checked the the grommets on the engine on the valve cover and they looked ok, only that there were a little bit lose, also tighten the screws on my air manifold were also lose and notice that inside of the manifold on the bottom there was some oil residue on it, I dont know if thats normal or not, my K&N filter is dry and not oily on it, still ligth on, all have to do now is check fuel pressure and injectors b4 I give up and just leave it like that, I mean the car runs smoothly with no problems except that CEL that wont shut off, well thanks for your good advice and I will keep on trying. Thank you.


Tiny
Miltongina
Jul 12, 2013.
I was reading back on this Webpage on past reviews and came up with this same code P0171 on this thread==>> http://www.2carpros.com/questions/chevrolet-cobalt-2005-chevy-cobalt-engine-check-p0171-code

I did change the MAF twice from the same Vendor on Ebay but I remember now on back march, 29, 2010 that I did buy that sensor en Oriellys and not on Ebay. Still my Car runs smooth with no problems but with that CEL P0171 on. Just wanted to let u know that I had that same problem on March 29, 2010.

Thank you.


Tiny
Miltongina
Jul 13, 2013.
Here's a tip you might look for found by another mechanic I still think it's an air leak.
Customer pulled in Friday night, Check engine light on P0171. Said has had it looked at several times at another shop, shows receipts, see that maf sensor and 02's have been replaced. They told her she needs new pcm.

Told her to drop off Saturday I'd take a look at it. While drinking my cup of coffee, started doing visual inspection, couldn't help but notice rubber lip around throttle body was rolled. Pulled apart, used heat gun to mold back in to shape. Had to been that way for quite awhile, due to all the dirt in throttle body, Cleared codes, and shipped it.

After some interesting words out of cutomers mouth, she made it very clear who would be working on her cars from now on. Cup of coffee didn't even get cold during complete repair! Is your fuel pressure at least 50-60 psi? If not that will cause it as well.


Hmac300
Jul 13, 2013.
Page 1 of 2