Mechanics

DIDN'T START

2004 Volvo XC70 • 78,000 miles

Turning the key didn't start the car. All lights, instrment panel lights and radio worked. Had battery tested - no problem there. Had it towed, started right up next morning. Had starter tested - tested ok. Had alternator tested - also ok.
Wondering what else could be wrong, as now I don't know if it will happen again.
Avatar
Renie
June 28, 2012.



Go to this link: http://www.2carpros.com/articles/car-engine-will-not-crank-over

Rasmataz
Jun 28, 2012.
I reviewed the link, thank you. But still don't know the answer. Starter was checked by a mechanic, is fine. Battey is fine.
I do believe it has to do with the anti theft, because the "Inhibitor, check manual" message comes on. But the light on the dash does not flash or go on.
Manual suggests s problem with code in key.
This has happened 3 more times since I first wrote - I have 3 keys and have tried all of them; none work when it refuses to start. Further, it happens only once in a while. A common denominator is a hot day, and a quick stop, like running to pick up the mail. Do you have any further words of wisdom given this information? I sure would appreciate it.
Thanks, Renie

Tiny
Renie
Jul 6, 2012.
Have the anti theft system checked further

Rasmataz
Jul 6, 2012.
Had a scan check done - supposedly found a faulty alarm siren and the immobilizer system was "missing". Scan check and fix cost $650.

Can you tell me why a faulty alarm siren causes the alarm to go off by itself only on very hot days, a "missing" immobilizer causes the car to not start only on very hot days, but it starts every time the temperature is below 90?

This feeds in to my previous question (2 years ago), on why all my ligths go out and the instrument panel goes haywire just before it goes completely black - only on very hot days. The fix for that is supposedly a new instrument panel.
Why do all of these things work at norman and cold temps, and go haywire when the temp goes above 90 degrees?

Tiny
Renie
Jul 11, 2012.