Mechanics

PONTIAC SUNFIRE FUEL PUMP PROBLEM

2004 Pontiac Sunfire • 170,000 miles

I have a buzzing from the relays under the hood. Very loud not your normal relay click. When this happens the car wont start. I have already cleaned all the relay terminals and the main power wire to the panel. Swapped all relays with known good ones. All this help but still does it sometimes. Resently had the iac solinoid replace due to carbon buildup so bad that when I tried to remove it to clean it iy broke and the magnet wires inside broke. Can here the fuel pump working have not had fuel pressure checked though. Engine light was on but the code was for evap (p0456).
AD
Avatar
Madeincanada
December 5, 2012.



Find out what relay it is that is buzzing so we can help you alittle more. It shold be marked under the fuse box cover

Hmac300
Dec 5, 2012.
It seems to be the fuel pump relay, but its kinda hard to tell because the vibrations are traveling through the entire panel. Like I said its a very loud buzz. Thanks for the quickness of the reply.

Tiny
Madeincanada
Dec 10, 2012.
The relay may be bad, try disconnecting it to see if it stops, if not that one keep pulling them until you find hte one that is, it won't hurt anything, the most that wold happenis the car qouslquit running.

Hmac300
Dec 10, 2012.
Ok so I tried pulling the relays it is the fuel pump relay but I put a new relay in and it still does the same thing.
AD

Tiny
Madeincanada
Dec 12, 2012.
Then you'll have to check for a short on that circuit.

Hmac300
Dec 12, 2012.
Thats what I was afraid of. Thanks for the help.

Tiny
Madeincanada
Dec 28, 2012.

AD