Mechanics

HONDA CIVIC ENGINE PROBLEM

2004 Honda Civic • 202,400 miles

2004 Honda Civic
? Regular transmission
? ES5
? Singapore Car

PROBLEM:
The engine check light comes on when the car reaches anywhere above 80 km/h

HISTORY
1. Problem: November 16, 2012 --- 202300km. The car was overheating (Temperature gauge increased to about five strokes half mark on gauge).
Solution: I removed the thermostat

2. Problem: November 17, 2012 ---- 202392 km. Regular Servicing.
Solutions:
i) Replaced engine oil with Honda Synthetic Blend 10/30W and Honda Engine oil filter. (This type oil and filter is always used)
ii) Replaced transmission fluid (Regular transmission) --- ATF – DW1. Last changed was August 27, 2011 with Honda ZTF – Z1– Mileage 156377km. I was told on November 27, 2012 that ZTF – Z1 is no longer being made.
iii) Changed air filter

3. Problem: November 21, 2012 – Car continued to overheat.
Solutions:
i) I rod the radiator and refill with coolant
ii) I removed engine head and skim it (Removed 1 tow from engine head).
iii) I replaced head gasket with Genuine gasket Part number 12251PLC – 004
iv) I replaced the topics cover gasket to a genuine gasket
v) PCV valve was broken and I replaced the PCV valve with Purelator brand

On completion of this engine work, the car went for test drive by me and the engine check light comes on when the vehicle reaches 100km/h

4. Problem: November 23, 2012 – Engine check light still on and the car sputtering and misfiring.
Solution:
i) I went to three separate computer diagnostic and the scan tool showed “Code P1259 VTEC system failure and VTEC system malfunction.
Solution:
a) I changed the VTEC solenoid
b) I changed the VTEC oil pressure switch.
c) The battery terminal was removed and the engine checklight reset

On completion of this, the car went for test drive by me and the engine check light comes on when the vehicle reaches 120km/h

The engine oil level is ok.
The battery is ok at 12.6V
The engine no longer sputter or misfire.
No visible oil leaks
No smoke from exhaust
The car does not lose power.

What is wrong?
Avatar
Clareen
November 27, 2012.



Since problem only occurs at high speed driving, check the oil strainer for clogging.
When cylinder head was removed, was it heavily sludged?
Was oil treatment ever used on this vehicle?

KHLow2008
Nov 27, 2012.