Mechanics

MY TAILIGHTS ARE BOTH OUT. FUSES OK, PARK LAMP RELAY OK. WHAT'S THE POSSIBLE NEXT STEP OR SOLUTION?

2004 Chevrolet Express • 170,000 miles

My license plate lamp is also out and I would like to check the bcm but I don't know what pin to check for voltage. Also the front park lamps only come on when the engine is running and in gear. Hazard work, brake lights work, headlights work and turn signals both front and rear.
Avatar
Jaksun
March 15, 2012.




The schematic indicates the taillights are not linked to the BCM.

You are not getting powwer to the lights.
I would suggest starting by checking the power supply to the switch and out put to the taillights.

At the light switch, check for battery voltage to Orange wire. It should be hot at all times.

If power is available, turn on lights and Brown wire should have battery voltage. If it does not, the switch is bad. If brown wire has bettery voltae, check the wiring connections between switch and bulbs.
Are the interior illumination lights working, eg, for switches etc?

KHLow2008
Mar 15, 2012.
Hello again and thanks for your help, I've checked for power on the orange conductor at the switch and found none. I've re-checked the fuses and all are ok.

Tiny
Jaksun
Mar 16, 2012.
And yes the dime lights are all working as well.

Tiny
Jaksun
Mar 16, 2012.
I just found the problem. The ground in the body fuse block was totally corroded looks almost like someone spilled something on the fuse block. Cleaned the ground with a wire brush and bang went the relay.
Thanks again for your help. Much appreciated.

Tiny
Jaksun
Mar 16, 2012.
You're welcome. Glad to know you have fixed the problem.

Have a nice day.
AD

KHLow2008
Mar 16, 2012.

AD