Mechanics

BMW 330 NOISE PROBLEM

2004 BMW 330 • 92,000 miles

I just bought a 04 BMW E46 330i with the sport package, It sounded alright when I got it but then it makes this noise only at idle and when I rev the engine it goes away or the noise diminishes quite a bit. Also the engine does not make the sound right at start up usually when it gets to normal operating temperature does it start making this noise. The noise is like a galloping, rotating chain clanking, slapping noise, but it sounds fine and when I put foot on the brake and rev the engine and it also goes away and when I rev the engine. Does not sound like a vanos rattle or chain tensioner noise I just replaced the primary chain tensioner and it quieted the noise quite a bit.

here is a video of the noise
http://www.youtube.com/watch?v=f_tnQRQt6BI&feature=plcp

here is a broken link just incase I can't post links yet

hxxp: // w w w (dot) youtube (dot) com / watch?v=f_tnQRQt6BI&feature=plcp

Things I have already checked or changed

-DISA
-Idler Pulley
-tentioner pulley
-Water pump
-thermostat
-radiator flush but not the engine block flush
- changed the oil
- belts and pulley all are good
- fan clutch seems to check out fine
- I have heard it could be vanos seals but that is a different rattle from what I can hear.
- doesn't knock with acceleration so don't think it is the rod knock

Please help this probably will only be able to be answered by a BMW enthusiast because I have asked numerous people and they can not figure it out and I have changed alot of things and they made no difference.

Please help

Thank you
Brandon



Avatar
Brarkus
November 3, 2012.




From my experience, noise can be difficult to diagnose from cyberspace. The link is not functional.

Dr. Hagerty
Nov 5, 2012.
I cant post links on this forum yet, so until then I put up a broken link it is the same as a link just control copy, control paste and get rid of (dot) and xx in hxxp basically if you put

watch?v=f_tnQRQt6BI&feature=plcp

on the end of a youtube link

http://www.youtube.com/ watch?v=f_tnQRQt6BI&feature=plcp this link probably wont work but if you put it together it will work

If I just put up the link they will cut it off and it will just go to You tubes home page

it will go to the video they wont let video posting for me yet anyways.

Tiny
Brarkus
Nov 5, 2012.
You state, "does not sound like a VANOS rattle or chain tensioner noise" I would like to know what has you say that? Are you sure you know what a VANOS rattle sounds like?

Dr. Hagerty
Nov 6, 2012.
Well In the beginning I thought it was a different sounding galloping clanking noise, and it disappears underload and under acceleration. I believe the car has a mild vanos rattle but the really bad sound only happens at idle and when I push the gas and turn while accelerating in a take off it makes it louder. But then when straightening it out of the turn and driving off it goes away and sounds fine.

* We have heard possibly a loose timing chain we changed primary tensioner and thought we may have to get in a change the upper tensioner but didn't want to open up the whole engine. And I wanted to try to pinpoint what it is because I have been changing all the usual suspects but that did not change the clanking galloping sound.

Can a vanos rattle sometimes sound like clanking galloping noise only at idle? Or does it only usually rattle when accelerating and idle.

I have thought maybe the vanos seals but they are more of a rattle with RPMs mine goes away with rpms especially under load but if I hear alot more people say loose timig chain I was going to open it up and change the upper timing chain tensioner and vanos bearings and seals.

I have not ruled out VANOS it just sounds like somthing else in my opinion.
AD

Tiny
Brarkus
Nov 6, 2012.
This is the main video of the noise

http://www.youtube.com/watch?v=f_tnQRQt6BI

broken link below just in case top one is not working

http://www.youtube.com/ watch?v=f_tnQRQt6BI

THis is the video after I changed primary chain tensioner it got quieter a little but still comes back loud sometimes like in the first video I hope these videos will be posted hopefully

http://www.youtube.com/watch?v=6_x7S4-3oaE

broken link below just in case top one is not working

http://www.youtube.com/ watch?v=6_x7S4-3oaE

Tiny
Brarkus
Nov 6, 2012.
Where in the country are you?

Dr. Hagerty
Nov 7, 2012.
Im in the US in Boise Idaho

Tiny
Brarkus
Nov 7, 2012.
Maybe a busted tensioner rail

Dr. Hagerty
Nov 8, 2012.

AD