Mechanics

MY 02 GAS GAUGE,MOT WORKING,CHECK ENGINE LIGHT ON,POOR ACCELORATION

2002 Saturn L300 • 150,000 miles

I was messing with the a/c cycle switch because my a/c wasent working and I was putting direct power from the battery, when I was doing something started clicking while I was doing it and then the car died but then it started right up but then my gas gauge whent all the way to empty my check engine light turnd on, slow acceloration started, when I turn the check engine light of with the scaner my gas gas light turns on for a couple of seconds then it turns of then the check engine light turns back on can someone help?
Avatar
Gomez23
June 25, 2012.



So did you add power at the ac pressure switch on the ac line?So what codes are you reading in the computer?Is there anything else not working besides the gas gauge?

Saturntech9
Jun 25, 2012.
Sorry I wasent adding power I was just cheking the power on the pressure switch, I was getting a p1283, P0453, P0463, P0405, P0402, the gas gauge is the only gauge not working

Tiny
Gomez23
Jun 25, 2012.
You have some egr codes a gas pedal position sensor position sensor code a fuel tank pressure sensor code and a fuel level sensor code.I think your looking at a 5 volt refrence circuit issue or a ground issue. Do you have a scan tool that reads live engine data?

Saturntech9
Jun 25, 2012.
Yes I could get ahold one, thank u so much for ur help

Tiny
Gomez23
Jun 25, 2012.
Your welcome keep me posted.

Saturntech9
Jun 25, 2012.
Ok so what do I look for on the scaner?

Tiny
Gomez23
Jun 26, 2012.
Now here comes the tricky part I dont know what inputs your scan tool will be able to read on that car. Hook up the scan tool and read live engine data on the car see if it displays the egr valve app sensor or fuel tank pressure sensor/ftp sensor voltages?Let me know what you find.

Saturntech9
Jun 26, 2012.
Sorry I just got back I had to go out of town for a few weeks but ill hook it up to the scaner first thing tomorrow. Sorry for the hold up

Tiny
Gomez23
Jul 27, 2012.
Thats ok keep me posted.

Saturntech9
Jul 27, 2012.
Tank pressure (v 5.00),
Tank prs mmHg21: 9
App 1 v. 0.41
App 2 v. 2.49
App at idle- yes
EGR sensor (v) o
One thing I forgot to mention is that my cruise control isn't working either.

Tiny
Gomez23
Jul 30, 2012.
Page 1 of 2