Mechanics

MERCURY MOUNTAINEER THERMOSTAT PROBLEM

2002 Mercury Mountaineer • 117,000 miles

Hello, I noticed today after I had been at work for a while, that when I came out to my car there was some fluid on the pavement. It looks like either power steering fluid or oil. I do notice when I turn my wheels all the way to the left or right, there is a slight vibration-ish noise. Could this be my pump going bad or one of the hoses leaking or should I try filling my reservoir and see if it continues because it does look low to the naked eye but I want to double check it with a dipstick. I do also want to check the oil filter/housing gasket too to see if that's the issue if there are any noticeable oil drips as well.
Avatar
Mbullion
November 17, 2012.




Top off all fluids and have the systems checked for leaks

Roy

ASEMaster6371
Nov 18, 2012.
I forgot to mention that I have a cracked thermostat (pretty common with these cars) that I am getting fixed Tuesday. Anti-freeze is coming out but not severely by any means. At first I thought it could have been that but I checked the color and it didn't match. Could that still maybe it?

Tiny
Mbullion
Nov 18, 2012.
Doubt it. Cracked thermostat? I have never seen this unless the t stat was installed incorrectly.

Roy

ASEMaster6371
Nov 18, 2012.
My bad. The intake manifold cracked NEAR the thermostat causing coolant to leak.
AD

Tiny
Mbullion
Nov 18, 2012.
Ok, better, that is a common failure

ASEMaster6371
Nov 18, 2012.
Just an update: definitely the cracked manifold. Just looked at the pavement again today and saw anti-freeze. Not a ton but I think it's getting worse. Having it fixed Tuesday

Tiny
Mbullion
Nov 18, 2012.

AD