Mechanics

CHRYSLER CONCORDE FUSE PROBLEM

2002 Chrysler Concorde • 1 miles

The instrument panel (rpm, speedo, odometer, gas gauge) and the taillights don't work. We pulled the fuse #7 for those items and cleaned the terminal and replaced it with a new 20 amp fuse. Still the same problem.
Avatar
Guest
February 3, 2013.



The cluster may have failed. Remove the cluster and clean the connections behind it.

Roy


What about both taillights not working?


Tiny
Deedee2009
Feb 3, 2013.
Ok, that may be a different issue. There is a fuse for the tail lights, check that

check the sockets for power with a test light. Does the license light work?

Otherwise look at grounds and the wiring in the trunk

Roy


The fuse for the tail lights is also the fuse for the instrument cluster. I did check the socket that the fuse plugs in to and there is no power going to the fuse. The license light does not work. So, if there is no power going to the fuse how do I remedy that problem? Is this an easy fix?


Tiny
Deedee2009
Feb 4, 2013.
Diagram below that has a park lamp relay. Check this for power when the headlight switch is on

Roy


This diagram does not compare to the fuse/relay box under my hood. I have taken a picture of it. If you could send me your email address I can send you a picture of what mine looks like.
Thanks,
Deanna


Tiny
Deedee2009
Feb 4, 2013.
Tell me how I can donate more money to get this question answered to my satisfaction. The fuse/relay diagram you showed me is not the same setup as I have under the hood. Can I send you a pic somehow of what my setup looks like?


Tiny
Deedee2009
Feb 4, 2013.
Sorry, at work with no acess today.


Roybelding@gmail. Com


Hello?


Tiny
Deedee2009
Feb 6, 2013.
Page 1 of 2