Mechanics

CAR WONT ACCELRATE WHEN GAS PEDAL IS FULLY PRESSED, SHOWS ON RMPS IT IS ACCLERATING, STALLS WHEN HOT BUT IF I POUR WATER ON THE MOTOR IS RUNS?

2001 Pontiac Montana

My husband and I bought a 2001 montana, the car has had problems ever since. At frist when the van gets hot it wouldnt crank unless it set for at least 30 mins or you poured water over the motor (which is Bad to DO) NOw it Hesiates when gas pedal is fully pressed, backfires, and shutters it accels when you let off the pedal slowly and gently press it again, but once it gets 50 miles and hr it runs fine. We have replaced the Camshaft sensor, already any clue where to go from Here?
Avatar
JeorgeAnn
September 5, 2012.



Scan for codes and check fuel pressure first. Most auto parts stores will scan for free. It cold be something else but start there.

Hmac300
Sep 5, 2012.
Did all that. We replaced camshaft sensor, still has same problem. Its even worse actually, but it was worse before replaced the camshaft sensor. If you want to crank it you have to pump the gas alot. When it cranks its slow to take off and it backfires alot, but once you get it going you have to barely press the gas or it bogs back down and you have to press the gas and release it slowly til its barely pressed again and it will get to about 60. We checked the codes it says fuel system lean we replaced all the filters and even had the fuel pump tested. Ever here of this?

Tiny
JeorgeAnn
Sep 10, 2012.
Check your engine vacuum if it's 15" or belwo suspect a clogged converter. Also what was the fuel pressure? This could also be a crank sensor that has to many ohms and gets hot and is not working right. Whay was the cam sensor replaced anyhow?

Hmac300
Sep 10, 2012.