Mechanics

P0502 LOW VOLTAGE

2001 Oldsmobile Bravada • 170,000 miles

Engine light came on. Lost speedometer, transmission now shifts erratically.
Pulled codes, P0502 - checked all breakers, replaced VSS, still no change. Now Engine light, ABS and AWD lights now on! Seems to be cascading! Having been working on P0502 code before I tackle the others.
Avatar
Jlcrislip
April 17, 2012.




Any other codes now?

Tiny
Fixitmr
Apr 17, 2012.
Yes, P0410, which I have been working on since last inspection. Had it fixed and it returned within 1 week.
ABS codes: B0223/226/236/237/265.
Also forgot to include the fact that I have replaced my alternator due to low voltage.
Having done all this, I have not had the codes cleared either by disconnecting the battery or having a friend with a diag meter clear the codes.

Tiny
Jlcrislip
Apr 17, 2012.
You may have to test harness for VSS.

Tiny
Fixitmr
Apr 17, 2012.
By test harness do you mean the VSS connection and cable? Could this one issue lead to the others?
AD

Tiny
Jlcrislip
Apr 18, 2012.
Yes, the continuity to PCM.

Tiny
Fixitmr
Apr 18, 2012.
Update: I got so frustrated, that I took it into the local dealership. $300 later, I find that it has 3 VSS, all the same part number but different locations. The dealer replaced the failing one and charged me the labor. None of the Autozone pics showed three. The dealer parts guy showed me the same pic but did not show me the location of the other two.I would really like to see a pic/diagram of the exact locations. For the $300, I could have bought all brand new VSS and replaced them my self and still had money to take my wife out to dinner. Live and learn! Hey, all the dash lights are out and it shifts normally.

Tiny
Jlcrislip
Apr 27, 2012.
Sorry, forgot, yes, the speedometer and odmeter are working as well!

Tiny
Jlcrislip
Apr 27, 2012.
Had this code and I orderd the speed sensor from rockauto parts, it arrived I replaced the part and the check engine light came back on, I called and asked if they could send me a replacement, yes they replied if its faulty, Well it doesnt work I replied, did you put it on the vehicle already I was asked. Yes I did, Then unfortunately we cannot give you a refund or replacement they stated! Ok so it doesnt work but because I put it on my vehicle you wont refund my money, YES! So can I send it back, yes but only if its faulty, IT DOES NOT WORK, I WILL SEND IT BACK, " YOU WILL NOT GET A REFUND FOR A PART YOU HAVE HAD ON YOUR VEHICLE SIR!

So advice from me. Do not use Rockauto. Com for parts, they will rip you off, pay the extra and use a recognised shop, they will take back the part if it is faulty !

Tiny
Simonhalfpenny
Sep 15, 2012.

AD