Mechanics

FORD EXPEDITION DEALER PROBLEM

2001 Ford Expedition • 150,000 miles

My 2001 expedition 5.4 blew up a coil & spark plug #8. I replace spark & coil but it doesn't want to start. Anti theft light is blinking rapidly & is killing battery. I think the coil made a short when hitting firewall. What should I do? Think u, please help.
Avatar
Santiagocorrales
February 28, 2013.




Did you remove a battery cable for this operation?

It sounds like a security failure and ford is the only one who can re program it.

Roy

ASEMaster6371
Feb 28, 2013.
Yes, I remove positive cable. So u think I did not fried the computer brain?

Tiny
Santiagocorrales
Feb 28, 2013.
I did not say that and no, you did not.

It sounds like a security issue triggered by you removing the cable

Roy
AD

ASEMaster6371
Feb 28, 2013.
I call a lock Smith and told him what happened. He said that it was a electrical problem. I told him when I turn key to on, all gauges go up and down & my odometer is just shows little dots.

Tiny
Santiagocorrales
Feb 28, 2013.
Thats new information you did not state.

There is a gem module or bcm that may have bearing on this.

Either way, you will need a shop to confirm this as it would an expensive guess either way. Lets be sure.

Roy

ASEMaster6371
Feb 28, 2013.
So the right thing to do is take it to dealer. How much u think I'm looking at? Think u Roy. How I can send it donation.

Tiny
Santiagocorrales
Feb 28, 2013.
Not the dealer but a good shop as the dealer will be the most expensive here.

Go back to your original post and there is a link for donations

Roy

ASEMaster6371
Feb 28, 2013.

AD