Mechanics

ODOMETER READING 1/4 OF MILAGE I DRIVE, SPEEDOMETER WORKS FINE

2001 Chrysler PT Cruiser • 27,000 miles

2001 Chrysler pt cruiser, odometer registering 1/4 of milage I actully drive, drained power from whole system to reset the computer. Nothing, replaced PCM, nothing. All gauges during the self test check out fine, also the speedometer is working fine, odometer and trip is the problem


Avatar
Freshman6969
June 22, 2012.



If the tires are the stock size, I would look at the vehicle speed sensor as a probable source for the issue.


Replaced speed sensor today, still the same thing, are there other speed sensors? The one I replaced was under the battery tray and air box, im running out of ideas here


Tiny
Freshman6969
Jul 8, 2012.
Was the speed sensor attached to the transmission?
I have never seen one that is not.
You of course always have the psosibility that the speedometer is broken. You should get one from s a salvage yard. If you need help locating one, the search eninge on this site will help to find one near you. Just look at the ads that come up on the page.


Yes it was, I know my speedo works because I went through a speed trap located down the road from me a few times carefully noting the speed I was going and what the speed trap said, all is good there, next week im going to see if the VSS wire is grounding out somewhere, it just boggles my mind that its ONLY the odometer not working, again I appreciate the answers


Tiny
Freshman6969
Jul 13, 2012.
There are 2 wriing diram and achjart location of each ground. Gave you the side of the engine and transmission with the VSS on it. I also sent the sensors location.