Mechanics

LINCOLN TOWN CAR TERMINAL PROBLEM

2000 Lincoln Town Car

2000 Lincoln Town Car wouldn't start a few days ago. I turned the key and the entire dash went black. No lights, no sound, nothing. Looked under the hood and the positive battery post and terminal was heavily corroded. A jump start wouldn't work, but tweeking the terminals and cleaning the corrosion did.

When I got home and tried to start it again same problem. So I changed the terminals. The car starts fine now. Fires up better than ever, however now my hazard lights wont stop coming on and off. When I open the car door they start blinking, when I start the car they start blinking, as I drive the car they blink for about 10 seconds, stop for a few seconds, then start blinking again.

There's also a red light on my dash (behind the turn signal, next to the lights dim switch) that continues to blink. 5 blinks, pause, 5 blinks. It wont stop blinking as I'm driving, and continues to blink as the car is parked and turned off. I never noticed this light before, and don't even know what it belongs to. I know the blinking light on the windshield defrost vent that blinks when the car is parked is the antitheft, however this light behind the turn signal had never blinked before to the best of my knowledge.

I was told this is happening because I disconnected the battery while changing the terminals. So now the cars computer has to be reset. I was given several things to try which I did-I took the terminals off and made sure they were clamped to the connecting wires tightly, I held the neg and pos terminals together for about 5 mins then reconnected them to the post, I started the car and let it idle for about 10 mins, I turned the key into the on position and let it sit for about 10 mins. None of these things seemed to work for my hazard lights still come on when I open the door, and still turn on and off when the car is turned on. Red light on the dash continues to blink as well. Any solutions, suggestions, or being pointed in the right direction is greatly appreciated. Thank You.
Avatar
Brenda01
November 16, 2012.




As a means of fixing this problem I tried disconnecting the battery over night. Someone said that should reset the computer. Well when I put them back on this morning, the car wouldnt start. It had been starting and driving all week before this. Hazard lights still blink. Antitheft light is still blinking. Dash lights are on. The engine just wont fire. I can only guess the antitheft has been activated thus the car wont start. Im not sure, but thats my guess based on stuff Ive read online.
AD

Tiny
Brenda01
Nov 17, 2012.
I guess I should have waited for an answer before disconnecting the battery over night. Im still hopeful this is something I can do on my own.

Tiny
Brenda01
Nov 17, 2012.
A jump start got the car back running. Ive turned it on and off and driven it to the store. Had the battery and alternator tested at autozone. They both tested fine. According to the guy there leaving the terminals off all night is why it would not fire up. So now the car starts, but I'm still back to my original problem. Hazard lights, and light on dash continually flash. Hazard lights start when I open the door, and continues while I drive. They'll turn on for a few beats, turn off for up to a minute, then start back flashing. Dash light continually flashes while driving and while the ignition is off.

Tiny
Brenda01
Nov 18, 2012.

AD