Mechanics

CHEVROLET S-10 STARTER PROBLEM

2000 Chevrolet S-10 • 101,471 miles

Starter will not disengage after engine starts. I have to pull the starter relay (in fuse block under hood) to stop the starter. I can re-install the relay after the engine is shut off until the next time I start the truck. The starter engages and starts the engine as normal, but it won't disengage. I replaced the starter with a new one today, but still same problem. Wondering if it could be the ignition switch. Need help, any suggestions would be most helpful.
Avatar
Allenharter
February 3, 2013.




Have you tried a new relay?

Well, sort of, I swap it with another just like it from a different slot with no change, So, I have to think it is not the relay.
AD

Tiny
Allenharter
Feb 3, 2013.
You're right. Is the starter running or is it just stuck on the flywheel?

When the engine starts the starter keeps running until I pull the relay. Have to leave relay out until I shut engine off.

Tiny
Allenharter
Feb 3, 2013.
It sounds like the power from the ignition switch isn't shutting. Check the ignition switch to see if that is the case.

Ok, thanks for all your input. I think I will replace the ignition switch tomorrow, it only coast $65.00 at our local auto zone. I will post the results after I get it installed. Thanks again.

Tiny
Allenharter
Feb 3, 2013.
You may want to check it before spending the money. Let me know.

Well, just got home, My son-in-law and I had a time of it but we got the new ignition switch installed but it had no effect on my problem. The starter still continues to run after the engine starts. Only way to stop it is to pull the starter relay. Where do I go from here, I'm at a loss!

Tiny
Allenharter
Feb 4, 2013.

AD