Mechanics

INDICATOR LIGHTS WORK FOR ONE TURN THEN STOP WORKING, HAZARD LIGHTS DON'T WORK EITHER

1999 Saturn SL2 • 100,000 miles

I have a 1999 Saturn SL2 with just over 100,000 miles on it. Recently I have been having issues with the indicators. I turn my left or right indicator on and it will sometimes work. However, usually, when I flip the indicator, nothing happens (no sound, no lights). I'd assume that all my indicators were burnt out, but they seem to work occasionally (usually only one or two turns at a time). I have also noticed that sometimes it works if rather than flipping the indicator all the way, I simply press it towards the left/right (up/down on the steering column) position, right before the trigger point. Oddly enough, I have discovered that by pressing the hazard light button on top of the steering column, this seems to allow me to get one or two signals out of the indicators (I can see the indicators light up and hear the blinking, when it is not working I flip the indicator and there is no light or blinking sound). The odd thing however is that the hazard light button itself appears to do nothing, as pressing it does not activate my hazards. What could be causing this?
AD
Avatar
Rockymtnsaturn
June 6, 2012.



You could try squirting some contact cleaner in there and see if that helps?

Tiny
Fixitmr
Jun 6, 2012.
There was also a recall on hazzard switches that yr.
AD

Tiny
Fixitmr
Jun 6, 2012.
Think it was for LS model i'm having dislexia?

Tiny
Fixitmr
Jun 6, 2012.
Just to add to this one I was going to say it was the LS model that had the hazzard switch/flasher relay campiagn I remember doing them on the brand new cars we hadnt even sold yet. Sounds like a bad flasher relay thats the number one cause for issues your having in those cars. The flasher is on the drivers side behind the forward kick panel just in front of the center console. Its plugged into the back side of the inside fuse box.

Saturntech9
Jun 6, 2012.
If it's the flasher relay, how do I go about fixing that? Is it something I can do myself? Do I have to take it in to the shop? Any idea how much something like that would cost? I should also add that the switch on the windshield wipers that adjusts the speed within each stage does not work. I.E. I can flip it to slow and it will go, or medium and it will go faster, or fast, and it will go fast, but the dial that adjusts to 1, 2, 3 within each of those speeds does nothing anymore.

Tiny
Rockymtnsaturn
Jun 6, 2012.
So are you saying your intermintant position no longer works in the 1 2 or 3 position?The 123 only works on the first wiper setting which is the intermintant position. As far as your turn signals go the flasher just unplugs into the back of your inside fuse box. Those going bad has been the most common reason for issues with the turn signals I have seen on those cars. Do you have a test light to do some testing as far as the turn signals go?

Saturntech9
Jun 6, 2012.

AD