Mechanics

CAR DIES AT IDLE AFTER REPLACING THE ALTERNATOR.

1999 Mitsubishi Galant • 168,000 miles

I had this happen before and I just drove it for a while to let the computer re-learn itself, but this time the battery drained while I was driving it around. I inspected the plugs and everything is connected. I also replaced the belt. Any idea what thiscould be?
AD
Avatar
Jamesh5489
September 16, 2012.



How far did you drive the car? Sometimes you need to drive it on the highway but it takes only about 10 minutes.

Was the check engine light on before replacing the battery? There may be other issues with the idle than re learn

Roy

ASEMaster6371
Sep 16, 2012.
I was on the highway for about ten minutes when the battery diedNo check engine light. The car didnt actually die until I stopped though. The battery and brake light started flashing then I got off the freeway and it died as soon as I hit under 1000 or so rpms.

Tiny
Jamesh5489
Sep 16, 2012.
The battery was drained completley.

Tiny
Jamesh5489
Sep 16, 2012.
Sounds like you have lost the alternator. Check the voltage at the battery with the engine running. It should be 14 to 14.5 volts.

Roy

ASEMaster6371
Sep 16, 2012.
SOUNDS LIKE THE ALTERNATOR YOU JUST INSTALLED IS EITHER NOT CHARGING OR NOT GETTING THE JUICE BACK TO THE BATTERY

CHECK YOUR FUSES AND FUSIBLE LINKS---OR EVEN THE ALTERNATOR (NEW STUFF CAN BE BAD TOO!)

http://www.youtube.com/watch?v=Bzz7P3qNHcE

YOU'LL KNOW WHAT TO LOOK AT IN THIS LINK, AS FAR AS CONNECTIONS GO

http://www.2carpros.com/questions/1996-chevrolet-tahoe-wont-start-sounds-dead-battery-jumpbox-get-same-reults

KEEP US POSTED ON HOW IT'S GOING

THE MEDIC
AD

Tiny
CJ MEDEVAC
Sep 16, 2012.
Thanks. Im gonna pull it out and get it tested. Ill let you know how it goes.

Tiny
Jamesh5489
Sep 16, 2012.

AD