Mechanics

LAREDO 4.0

1999 Jeep Grand Cherokee • 145,000 miles

Hi I have a 1999 jeep grand cherokee laredo 4.0 and I recently just got it running the other day it had some fuel problems but then I went back out the next day I had it running for like five mins and it was running rough so I gave it some gas to calm it down it sounded like it wasnt getting gas and then it just quit and wouldnt start back up again. Its getting fuel its just not starting I checked the pump and the filter and there good and there is fuel coming out of the rail but its just not running any awnswers would be helpful thank you. Shawn
Avatar
Rednex18
September 22, 2012.




What is the fuel pressure? We need that specs.

Jeeps are common for failing crank sensors that stop spark. If it is bad, it may have set a code.

Roy

ASEMaster6371
Sep 22, 2012.
Oh ok thank you and do the crank sensors stop it from running completley cause when I poor gas in the carb it starts for a few seconds but the funny thing is is that everything is getting gas

Tiny
Rednex18
Sep 22, 2012.
No, it is a fuel delivery issue. You may have fuel but not enough pressure. Looks more like the fuel pump.

Roy

ASEMaster6371
Sep 22, 2012.
Im not even sure when I put a screwdriver in the valve on the fuel line very little comes out it will only squirt over the end of the screw driver

Tiny
Rednex18
Sep 22, 2012.
Virtually no pressure present.

Roy
AD

ASEMaster6371
Sep 22, 2012.
Oh ok well I can hear the pump kick on but I might have to get a new one and its weird cause I just had it running the other day and that was the first time it was running since three months and that fuel pump and filter are brand new

Tiny
Rednex18
Sep 22, 2012.
Make sure you clean out the tank of all debris.

Roy

ASEMaster6371
Sep 22, 2012.

AD