Mechanics

CHEVY - COOLAND LIGHT

1999 Chevrolet Venture • 2WD Automatic •

I have 1999 chevy venture with a 4.3L V6 engine. The coolant light is on. I have checked the water level in the radiator and the coolant container. The radiator is full and the coolant container has coolant in it. I have concluded that I must have defective coolant sensor. I have replaced the coolant sensor (in the radiator) and I have still have a low coolant light on. I have unplugged the wire warness connection and test the voltage at the connector. I got 14 volts. I have tried another brand new sensor that I immersed in a cup of coolant and got the same reading, i.E. Low coolant light on when the sensor is emersed in coolant and connected to wire harness. What is the problem here? Any suggestions? Thanks!
Avatar
Jj962
April 22, 2011.



Is the lite on with low coolant sensor, disconnected?


JDL
Apr 22, 2011.
No. When I disconnect the sensor from the connector, the light goes off. Actually this is the way I am running the car now since I am sick of this light! I understand I don't have the feedback in case I am actually low on coolant. Thanks for replying to my note.


Tiny
Jj962
Apr 22, 2011.
Coolant level indicators can operate differently on different vehicles. Not sure about yours? I have seen level sensors that would turn on the lite if disconnected. If I understand the wiring on this, there should be no continuity between terminals B and C on the sensor itself. Is there is heating element on the sensor?

In the diagram the yellow wire is voltage, black is ground.


JDL
Apr 23, 2011.