Mechanics

MY WILL NOT START! I HAVE TRIED NEW FUEL PUMP, FILTER AND PLUGS... STILL NOTHING!

1999 Acura CL • 76,000 miles

HELP! I have a 1999 Acura CL. It's been an awesome car, but I'm having some troubles lately. One morning I went to start my car to leave for work, and it wouldn't start! I had just driven it the night before and it ran fine! No check engine light or any signs of why it might not be starting. After checking it out, I really thought it was the fuel pump. So I bought and replaced the fuel pump, filter and plugs - STILL will not start! Fuel is still not getting to the cylinder. I also checked all fuses and all were fine. After racking my brain over what it could be, I have 2 buddies that are telling me it could be a couple of things: #1 main relay or #2 crank sensor. I took out the relay to see if I could see any cracks, and it looked okay to me. Ironically our other car died too so we had to drop $600 into that to get it up and running. I need to fix the Acura, but I want opinions on what I should try first. Has anyone else had this problem or maybe have some insight as to what the problem may be?
Avatar
Vrb1283
March 24, 2012.




Did you try squirting some gas into intake to see if it fires?

Tiny
Fixitmr
Mar 24, 2012.
Yes, I did and it does fire.

Tiny
Vrb1283
Mar 24, 2012.
2.3 or 3.0?
AD

Tiny
Fixitmr
Mar 24, 2012.
3.0

Tiny
Vrb1283
Mar 24, 2012.
Does fuel pump prime cycle come on when key is turned to on? 2-4 seconds.

Tiny
Fixitmr
Mar 24, 2012.
Yes

Tiny
Vrb1283
Mar 24, 2012.
Have you checked injectors for pulse?

Tiny
Fixitmr
Mar 25, 2012.
Yes, and there is no pulse.

Tiny
Vrb1283
Mar 25, 2012.
Have you checked for codes to see if computer working right?

Tiny
Fixitmr
Mar 26, 2012.

AD