Mechanics

SATURN SL1 SENSOR PROBLEM

1998 Saturn SL1 • 11,700 miles

1998 Saturn, SL1, 1.9Ltr, can't believe this after doing all these repairs. My Service Engine Light came on driving to work. Is there a possibility after all of these sensors being replaced, the only one we haven't changed is the 02 Oxygen Sensor? Could this be my answer or is there anything else to check please. Thanks Margaret
Avatar
Mmshields2006
February 3, 2013.




First of all what are the exact code numbers not code descriptions you have?Also what did you replace? Without that info I can't even begin to help you.


Saturntech9
Feb 3, 2013.
Sorry am at work, will scan with the pocket scanner when I get home this evening, Have replaced throttle body sensor, idol air control sensor, also air coolant sensor. Will report back if I receive any codes. Thank you Margaret


Tiny
Mmshields2006
Feb 3, 2013.
You replaced the coolant temp sensor or air inlet temp sensor?


Saturntech9
Feb 3, 2013.
Hi finally made it home, yes the coolant temp sensor, it was
cracked on both sides and replaced it with a brass tip end. Since,
have put the pocket scanner on the car and receiving code P0440
EVAP Emission Control System Malfuncation. Could you please advise me where this is and what it is, as I have no idea. Will have to have a friend look at it for me. Thank you again. Margaret
AD


Tiny
Mmshields2006
Feb 4, 2013.
P0440: Could be a problem with the charcoal canister plugged-up, gas cap and purging solenoid


Rasmataz
Feb 4, 2013.
Its not a clogged charcoal canister its a large leak detected I posted the trouble tree for that code. But it takes a professional scan tool to do it.I would start by checking the gas cap you could have left it loose setting the code. Also inspect the gas cap seal for cracking spliting etc?


Saturntech9
Feb 4, 2013.

AD