Mechanics

HOW TO DETERMINE WHICH FAULT CODE PO303 IS COMING FROM

1998 GMC Jimmy • 6 cylinder Automatic • 198,000 miles

Hello, I have a 1998 GMC Jimmy 4.3L. I just recently did a tunup which includes all 6 sparkplugs, 6 wires + 1 coil wire, distributor cap and rotor; fuel filter. Now I get a code PO303. I took to autozone they said " a misfire on cylinder #3 and or fuel injector faults"; they are other faults too I think may not be the problem. I remove sparkplug #3 and checked the gap and reinstalled. I checked sparkplug wire with ohm meter and got similar results compared with other wires. The check engine light comes on when car seems idled; but it goes off after awhile. My check engine light is off now. The car drives smooth with the exception from time to time it seems to stall then drives good. It does have a rubber burning smell that is not noticable until you have drove for my then 30 minutes or so. I think that is just smell from new wires put on and it will die down over time. Currently, someone suggested to try "fuel injector cleaner" which I am doing now. If this fails, what be the best next course of actions? Thanks in advance.
AD


Avatar
Roycar71
January 5, 2012.



Many have reported problems when not using oem ignition parts. Also possible intake leak or bad/dirty injector. Lower compression on that cylinder could also effect it.

Tiny
Fixitmr
Jan 5, 2012.
Hmm, since I did not have any problems before tuneup. Could that rule out " intake leak or bad/dirty injector. Lower compression"? And perhaps be non oem parts. Currently it runs smoother now than before and no "check engine light". I put in some "Lucas fuel injecter cleaner today.

Tiny
Roycar71
Jan 6, 2012.
Sorry, reading long explanations things get missed/added especially if logically incomplete? We often write in shorthand since we already know what it means? And I read about a hundred a day sometimes. And way they are structured dont help sometimes. So you say all is fine now?

Tiny
Fixitmr
Jan 7, 2012.
Check engine light is off now. I have given it some "Lucas" fuel injector cleaner. It runs smooths. When ide at stops I can feel car shake a little like something is wrong. I will have to continue to monitor it. What could this shaking indicate? Thanks.
AD

Tiny
Roycar71
Jan 9, 2012.
To re inquire, car ran FINE before you tuned it up? No shake?

Tiny
Fixitmr
Jan 10, 2012.
Yes, but now it runs good too. But when idle I notice it shakes more then before. I guess maybe I have to rule this out as nothing until check engine light comes on.

Tiny
Roycar71
Jan 10, 2012.

AD