Mechanics

I HAVE A 1500 4X4. HAS 5.2 IN IT AUTOMATIC.THE 4WD ISNT WORKING BUT THE FRONT DRIVESHAFT SPINS. ALSO, IT DONT SEEM TO HAVE THE POWER IT SHOULD. IVE REPLACED THE PLUGS, CAP,AND BUTTON AND ITS STILL THE SAME. IT SEEMS TO MISS BAD WHEN IT GOES

1998 Dodge Ram • 189,000 miles

Ive tryed tune up. Lost on it now, and dont have a clue on the 4wd.
Avatar
Kevin228670
December 20, 2011.



Is the light indicating at 4WD? Scan the TCM/Computer for code/s if any present post them-

Check vacuum at axle shift motor

AXLE SHIFT MOTOR FUNCTIONAL TEST
Raise and support the vehicle. Disconnect the vacuum harness from the axle shift motor and connect a vacuum pump to the vacuum shift motor front port. See Fig. 2.
Apply 15 in. Hg (51 kPa) of vacuum to the front port and rotate left front wheel to fully disengage the inner and intermediate axle shafts (i.E, shift to two-wheel drive operation).
The shift motor should maintain the vacuum applied to the front port for a minimum of 30 seconds. If the motor does not maintain the vacuum, replace it. If the motor does maintain the vacuum, proceed to the next step.
Disconnect the vacuum pump from the vacuum shift motor front port. Connect the vacuum pump to the vacuum shift motor rear port, cap the port for the 4WD indicator lamp switch, apply 15 in. Hg (51 kPa) of vacuum to the rear port.
The shift motor should maintain the vacuum applied to the rear port for a minimum of 30 seconds. If the shift motor does not maintain the vacuum, replace it. See AXLE SHIFT MOTOR under REMOVAL & INSTALLATION. If the motor does maintain the vacuum, proceed to the next step.
Remove the cap from the port for the 4WD indicator lamp switch. If vacuum was present, the shift motor is functioning normally. If vacuum was not present, go to next step.
Apply 15 in. Hg (51 kPa) of vacuum to the shift motor rear port. Rotate the left front wheel as necessary and ensure that the inner and intermediate axle shafts are completely engaged. The axles must be completely engaged (i.E, shifted to 4WD operation) to open the port for the 4WD indicator lamp switch.
Determine if vacuum is present at the port for the 4WD indicator lamp switch again. If vacuum was present at the port, the shift motor is functioning normally. If vacuum was not present at the port, replace the shift motor. See AXLE SHIFT MOTOR under REMOVAL & INSTALLATION.
Connect the vacuum harness to the shift motor. See VACUUM HOSE ROUTING. Remove the supports and lower the vehicle.


Rasmataz
Dec 20, 2011.
The 4wd light does not come on.


Tiny
Kevin228670
Dec 20, 2011.