Mechanics

MY ENGINE SPUTTERS AT LOW SPEEDS

1998 Acura Integra • 4 cylinder 2WD Manual • 150,000 miles

1998 Acura Integra mileage: 150,000. My car has a problem that I took to several mechanics and they can't seem to diagnose a specific problem. My engine sputters at low speeds like below 30mph but runs excellent above 60mph. It idles fine in 'Park' but idles rough in 'Drive' while at the traffic lights and in traffic. The engine is strong and I get good gas mileage. I recently had the spark plugs and spark plug wires changed because the car was eating up oil and had black smoke coming out of the exhaust. The car was also burning up antifreeze. On an occasion this problem still occurs but it has become minimal. My main concern is the sputtering that happens when I'm in traffic or going at slow speeds. The cars idle is high but it won't die down in the middle of the road. It takes a couple seconds to take off when I step on the gas. I went to the Acura Dealers and they told me the problem was a diagnostic code 12, the code for the EGR. I had the oxygen sensor replaced as well as the EGR valves and had put in brand new radiator hoses. The sputtering problem still has not gone away and I don't know what to do. I don't want to keep putting money in my car unless it will solve the problem and it seems like the dealers were wrong about the problem. If you could solve my problem it would great! Thanks.
Avatar
2CarPros-Archives
October 8, 2010.




Your car may have a seeping head gasket and/or a cracked cylinder head that is allowing antifreeze into the combustion chamber. At low speeds this would cause a misfire or your car to run rough. A slight amount of coolant in the combustion chamber at higher speeds would not be noticeable. You should have your engine checked for a leaking head gasket.

Tiny
2CarPros-Archives
Oct 8, 2010.


AD