Mechanics

HELLO I HAVE A PETROL 1.6 . THE MOTOR RUNS AT IDLE BUT WILL NOT INCREASE REVS

1997 Opel Astra • 136,000 miles

The problem started about 1 month ago and since then the car has stood idle. Petrol and air filters have been replaced.
Avatar
Douglas McConnell
February 13, 2012.




Any engine warning lights on? Take a fuel pressure test?

Tiny
Fixitmr
Feb 13, 2012.
What happens when you try to increase throttle?

Tiny
Fixitmr
Feb 13, 2012.
Hello thanks for the response to my question. No warning lights on and when I open the throttle the revs stay the same, however this morning whilst fiddling I removed the wire to the (acceleration sensor) I think, and after plugging and unplugging this a few times the revs came up but the idle stayed high. Once switched off back to the same.

Tiny
Douglas McConnell
Feb 14, 2012.
Is the throttle plate clean?
AD

Tiny
Fixitmr
Feb 14, 2012.
I will strip today and check thanks, I have wiped in there and quite a bit of dirt was on the rag.

Tiny
Douglas McConnell
Feb 15, 2012.
When you said 'open throttle' did you mean move throttle plate? Do we know if it's responding to pedal?

Tiny
Fixitmr
Feb 15, 2012.
Hi the throttle plate responds, I did a complete strip and washed out the throttle plate and complete unit. I refitted using a new stepper motor Idle unit and managed to get the motor running. The revs took a while to pick up but then the idle was fine. I took a run for about 20 kms and all was fine except a little flat until the revs were up. I have ordered a Tps (Throttle position sensor) and when that arrives in the morning I will fit it and see. Thanks again, appreciated.

Tiny
Douglas McConnell
Feb 15, 2012.
Hello all the fault was with my crank gear. Key way on shaft was partially stripped. Replacement gear was R100 and car revved up normally.
Thanks forthe advice.

Tiny
Douglas McConnell
Feb 25, 2012.

AD