Mechanics

I HAVE A 97 OLSMOBILE THAT TURNS OVER BUT WILL NOT START AT TIMES. THOUGHT I HAD A FUEL PUMP PROBLEM SO I REPLACED IT. STARTED FINE THE FIRST COUPLE TIMES THAN WOULD NOT START. I COULD HEAR FUEL PUMP RUN AND HAD GAS AT THE FUEL RAIL SHRADER VALVE

1997 Oldsmobile Delta 88 • 150,000 miles

Car run great when it starts
Avatar
Kidscars
May 20, 2012.



Have you checked the codes. For free AutoZone will pull codes. If you have any let me know what they are.
When trying to start make sure you have a good spark at the plugs. If you relaced the fuel pump then it may be you are not getting a constant spark


ImpalaSS
May 20, 2012.
Also check your coil pack for any signs of leaking, discoloration etc.


ImpalaSS
May 20, 2012.
I checked for codes with obd 11 pocketscan code reader. The code that came up was p0336 crankshaft position sensor A ckt range/perf. I checked my haynes and am not sure if I will be able to replace this sensor. Can you give me some feedback


Tiny
Kidscars
May 20, 2012.
What is your engine liter size and the 8th letter on your VIN - I have changed them before - you should be able to.


ImpalaSS
May 20, 2012.
3.8 K the coil pack does not show any sign of leakage


Tiny
Kidscars
May 20, 2012.
Okay 3.8L Vin K is located henind right side of crank pulley. I have attached several pics. The main one, then I broke that down in case you couldn't see it good enough.


ImpalaSS
May 20, 2012.
Thanks for the info. Gona try replacing the crankshaft position sensor.


Tiny
Kidscars
May 20, 2012.